aboutsummaryrefslogtreecommitdiff
path: root/security/super/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/super/Makefile')
-rw-r--r--security/super/Makefile29
1 files changed, 19 insertions, 10 deletions
diff --git a/security/super/Makefile b/security/super/Makefile
index da08e6080998..6268aed61db2 100644
--- a/security/super/Makefile
+++ b/security/super/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: super
-# Date created: Fri Mar 18, 1997
-# Whom: David O'Brien (obrien@NUXI.com)
-#
+# Created by: David O'Brien (obrien@NUXI.com)
# $FreeBSD$
-#
PORTNAME= super
PORTVERSION= 3.30.0
@@ -16,17 +11,31 @@ EXTRACT_SUFX= -tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Allow others to run commands as root
+LICENSE= GPLv1
+
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
MAN1= super.1 setuid.1
MAN5= super.5
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} 's|\.\/mkdir_p -p755|mkdir -p -m 755|g' \
+ ${WRKSRC}/Makefile.in
+
post-install:
@${STRIP_CMD} ${PREFIX}/bin/super ${PREFIX}/bin/setuid
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${FILESDIR}/sample.tab ${FILESDIR}/sample.cdmount \
- ${WRKSRC}/barebones.tab ${EXAMPLESDIR}
- @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/sample.tab ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${FILESDIR}/sample.cdmount ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/barebones.tab ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>