aboutsummaryrefslogtreecommitdiff
path: root/security/testssl.sh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/testssl.sh/Makefile')
-rw-r--r--security/testssl.sh/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/security/testssl.sh/Makefile b/security/testssl.sh/Makefile
index efdfb7497c38..a2e52793c41a 100644
--- a/security/testssl.sh/Makefile
+++ b/security/testssl.sh/Makefile
@@ -2,6 +2,7 @@
PORTNAME= testssl.sh
PORTVERSION= 2.8
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= tobik@FreeBSD.org
@@ -44,7 +45,6 @@ CONFIGURE_ARGS= --openssldir=${OPENSSLDIR} \
enable-camellia \
enable-idea \
enable-rfc3779 \
- enable-ec_nistp_64_gcc_128 \
experimental-jpake \
-DOPENSSL_USE_IPV6
CONFIGURE_ENV= PERL="${PERL}"
@@ -57,6 +57,14 @@ CONFIGURE_WRKSRC= ${WRKSRC_openssl}
# unknown reasons.
MAKE_JOBS_UNSAFE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CONFIGURE_ARGS+= enable-ec_nistp_64_gcc_128
+.else
+CONFIGURE_ARGS+= no-ec_nistp_64_gcc_128
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/elif test_openssl_suffix/d' \
-e 's@: \# 5. we tried.*$$@else OPENSSL="${PREFIX}/libexec/openssl.testssl.sh"@' \
@@ -71,4 +79,4 @@ do-install:
@cd ${WRKSRC}/etc && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/etc
@cd ${WRKSRC}/utils && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/utils
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>