aboutsummaryrefslogtreecommitdiff
path: root/security/tor-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/tor-devel/Makefile')
-rw-r--r--security/tor-devel/Makefile45
1 files changed, 19 insertions, 26 deletions
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index 26a78671e567..fac518442fb0 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tor
-DISTVERSION= 0.3.0.3-alpha
+DISTVERSION= 0.3.1.3-alpha
CATEGORIES= security net ipv6
MASTER_SITES= TOR
PKGNAMESUFFIX= -devel
@@ -13,32 +13,32 @@ COMMENT= Anonymizing overlay network for TCP
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_mips64= Does not build: error: Need a uint128_t implementation!
-BROKEN_powerpc64= Does not build
-BROKEN_sparc64= Does not build: error: Need a uint128_t implementation!
+BROKEN_mips64= does not build: error: Need a uint128_t implementation!
+BROKEN_powerpc64= does not build: error: Need a uint128_t implementation!
+BROKEN_sparc64= does not build: error: Need a uint128_t implementation!
-USES= cpe gmake
+USES= cpe gmake pkgconfig
CPE_VENDOR= torproject
-#CPE_VERSION= ${DISTVERSION:C/-.*//}
-#CPE_UPDATE= ${DISTVERSION:C/.*-//}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}"
+CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}" \
+ --disable-lzma \
+ --disable-zstd
CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include" \
TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/" \
TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
-OPTIONS_DEFINE= MANPAGES STATIC_TOR TCMALLOC TOR2WEB TRANSPARENT
+OPTIONS_DEFINE= MANPAGES DOCS STATIC_TOR TCMALLOC TOR2WEB
+OPTIONS_DEFAULT=MANPAGES
OPTIONS_SUB= yes
STATIC_TOR_DESC= Build a static tor
TCMALLOC_DESC= Use the tcmalloc memory allocation library
TOR2WEB_DESC= (EXPERT OPTION) Faster but non-anonymous hidden services
-TRANSPARENT_DESC= Transparent proxy support
-
-OPTIONS_DEFAULT= MANPAGES TRANSPARENT
USE_RC_SUBR= tor
SUB_FILES= pkg-message
+SUB_LIST= USER="${USERS}" GROUP="${GROUPS}"
+PLIST_SUB= USER="${USERS}" GROUP="${GROUPS}"
GROUPS= _tor
USERS= _tor
@@ -48,11 +48,14 @@ CONFLICTS= tor-[0-9]*
STATIC_TOR_USES= ssl:build
STATIC_TOR_USES_OFF= ssl
-MANPAGES_BUILD_DEPENDS= asciidoc:textproc/asciidoc
-MANPAGES_CONFIGURE_OFF= --disable-asciidoc
-
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MDOCS} || ${PORT_OPTIONS:MMANPAGES}
+BUILD_DEPENDS+= asciidoc:textproc/asciidoc
+.else
+CONFIGURE_ARGS+= --disable-asciidoc
+.endif
+
.if !defined(USE_GCC) && empty(CC:T:M*gcc4*) && \
empty(PORT_OPTIONS:MSTATIC_TOR) && empty(ARCH:Mia64)
CONFIGURE_ARGS+= --enable-gcc-hardening
@@ -84,12 +87,6 @@ LIB_DEPENDS+= libtcmalloc.so:devel/google-perftools
CONFIGURE_ARGS+= --enable-tor2web-mode
.endif
-.if ${PORT_OPTIONS:MTRANSPARENT}
-CONFIGURE_ARGS+= --enable-transparent
-.else
-CONFIGURE_ARGS+= --disable-transparent
-.endif
-
pre-everything::
.if ${PORT_OPTIONS:MTOR2WEB}
@${ECHO_MSG}
@@ -116,12 +113,8 @@ post-patch-STATIC_TOR-on:
@${REINPLACE_CMD} -e "s@-ltcmalloc@${LOCALBASE}/lib/libtcmalloc.a@" \
${WRKSRC}/configure
-post-configure:
- @${REINPLACE_CMD} -e '\|^nodist_man1_MANS =|s|$$|$$(install_mans:=.1)|' \
- ${WRKSRC}/Makefile
-
post-install:
- @${MKDIR} ${STAGEDIR}/var/log/tor ${STAGEDIR}/var/run/tor
+ @${MKDIR} ${STAGEDIR}/var/log/tor ${STAGEDIR}/var/run/tor ${STAGEDIR}/var/db/tor
.if ! ${PORT_OPTIONS:MTOR2WEB}
check regression-test test: build