aboutsummaryrefslogtreecommitdiff
path: root/security/tor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/tor/Makefile')
-rw-r--r--security/tor/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index cf4453bafabc..c3750864c9f6 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tor
DISTVERSION= 0.2.3.25
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= https://www.torproject.org/dist/ \
ftp://ftp.bit.nl/mirror/tor/ \
@@ -31,7 +32,6 @@ MASTER_SITES= https://www.torproject.org/dist/ \
http://tor.spline.de/dist/ \
http://tor.taiga-san.net/dist/ \
http://tor.vesta.nu/dist/ \
- http://tordistua.reactor-xg.kiev.ua/ \
http://torproj.xpdm.us/dist/ \
https://torproject.antagonism.org/dist/ \
https://torproject.crypto.is/dist/ \
@@ -39,7 +39,6 @@ MASTER_SITES= https://www.torproject.org/dist/ \
http://torproject.jcsh.it/dist/ \
http://torproject.nwlinux.us/dist/ \
http://torproject.ph3x.at/dist/ \
- http://torua.reactor-xg.kiev.ua/dist/ \
https://www.coevoet.nl/tor/dist/ \
http://www.oignon.net/dist/ \
http://www.torproject.nl/dist/ \
@@ -89,7 +88,7 @@ MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGMAKE}
-USE_GMAKE= yes
+USES+= gmake
.else
MAKE_JOBS_UNSAFE= yes
.endif
@@ -137,7 +136,7 @@ TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/event2/libevent_openssl.a ${TOR_LIBEVENT_LI
.endif
.else
CONFIGURE_ARGS+= --enable-linker-hardening
-LIB_DEPENDS+= event-2.0:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS+= libevent-2.0.so:${PORTSDIR}/devel/libevent2
TOR_LIBEVENT_LIBS= -levent-2.0
.if ${PORT_OPTIONS:MBUFFEREVENTS}
TOR_LIBEVENT_LIBS:= -levent_openssl-2.0 ${TOR_LIBEVENT_LIBS}
@@ -149,7 +148,7 @@ CONFIGURE_ARGS+= --with-tcmalloc
.if ${PORT_OPTIONS:MSTATIC_TOR}
BUILD_DEPENDS += ${LOCALBASE}/lib/libtcmalloc.so:${PORTSDIR}/devel/google-perftools
.else
-LIB_DEPENDS+= tcmalloc:${PORTSDIR}/devel/google-perftools
+LIB_DEPENDS+= libtcmalloc.so:${PORTSDIR}/devel/google-perftools
.endif
.endif
@@ -199,8 +198,8 @@ post-install:
.if empty(PORT_OPTIONS:MTOR2WEB)
check regression-test test: build
- @( cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check )
+ @cd ${BUILD_WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
.endif
.include <bsd.port.mk>