aboutsummaryrefslogtreecommitdiff
path: root/security/tor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/tor/Makefile')
-rw-r--r--security/tor/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index da3af82250c8..146c04a300d5 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tor
PORTVERSION= 0.2.7.6
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= TOR
@@ -106,6 +107,10 @@ CONFIGURE_ARGS+= --disable-transparent
post-patch:
@${REINPLACE_CMD} -E -e "s@(-z) (relro|now)@-Wl,\1,\2@g" \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|lib/tor|db/tor|' \
+ ${WRKSRC}/src/config/torrc.*.in \
+ ${WRKSRC}/doc/tor.1.* \
+ ${WRKSRC}/doc/tor.html.in
post-patch-STATIC_TOR-off:
@${REINPLACE_CMD} -e "s@-ltcmalloc@${LOCALBASE}/lib/libtcmalloc.so@" \
@@ -119,6 +124,9 @@ post-configure:
@${REINPLACE_CMD} -e '\|^nodist_man1_MANS =|s|$$|$$(install_mans:=.1)|' \
${WRKSRC}/Makefile
+post-install:
+ @${MKDIR} ${STAGEDIR}/var/log/tor ${STAGEDIR}/var/run/tor
+
.if ! ${PORT_OPTIONS:MTOR2WEB}
check regression-test test: build
@cd ${BUILD_WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \