aboutsummaryrefslogtreecommitdiff
path: root/security/trousers/files/patch-dist_Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'security/trousers/files/patch-dist_Makefile.am')
-rw-r--r--security/trousers/files/patch-dist_Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/security/trousers/files/patch-dist_Makefile.am b/security/trousers/files/patch-dist_Makefile.am
new file mode 100644
index 000000000000..ba062c7db9d1
--- /dev/null
+++ b/security/trousers/files/patch-dist_Makefile.am
@@ -0,0 +1,19 @@
+--- dist/Makefile.am.orig 2014-04-24 18:05:43 UTC
++++ dist/Makefile.am
+@@ -1,14 +1,14 @@
+ EXTRA_DIST = system.data.auth system.data.noauth \
+ fedora/fedora.initrd.tcsd
+
+-install: install-exec-hook
++Xinstall: install-exec-hook
+ if test ! -e ${DESTDIR}/@sysconfdir@/tcsd.conf; then mkdir -p ${DESTDIR}/@sysconfdir@ && cp tcsd.conf ${DESTDIR}/@sysconfdir@; fi
+ if !NOUSERCHECK
+ /bin/chown tss:tss ${DESTDIR}/@sysconfdir@/tcsd.conf || true
+ /bin/chmod 0600 ${DESTDIR}/@sysconfdir@/tcsd.conf
+ endif
+
+-install-exec-hook:
++Xinstall-exec-hook:
+ /bin/sh -c 'if [ ! -e ${DESTDIR}/@localstatedir@/lib/tpm ];then mkdir -p ${DESTDIR}/@localstatedir@/lib/tpm; fi'
+ if !NOUSERCHECK
+ /usr/sbin/groupadd tss || true