aboutsummaryrefslogtreecommitdiff
path: root/security/zebedee
diff options
context:
space:
mode:
Diffstat (limited to 'security/zebedee')
-rw-r--r--security/zebedee/Makefile4
-rw-r--r--security/zebedee/distinfo2
-rw-r--r--security/zebedee/files/patch-aa226
3 files changed, 161 insertions, 71 deletions
diff --git a/security/zebedee/Makefile b/security/zebedee/Makefile
index 09d732dfbb37..69084eb7f38d 100644
--- a/security/zebedee/Makefile
+++ b/security/zebedee/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zebedee
-PORTVERSION= 2.2.2
+PORTVERSION= 2.4.1
CATEGORIES= security
MASTER_SITES= http://www.winton.org.uk/zebedee/ \
http://www.hewgill.com/zebedee/
@@ -22,7 +22,7 @@ USE_OPENSSL= YES
USE_PERL5= yes
MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS=${PTHREAD_LIBS}
+ PTHREAD_LIBS=${PTHREAD_LIBS} \
MAN1= zebedee.1 ftpgw.tcl.1
diff --git a/security/zebedee/distinfo b/security/zebedee/distinfo
index 8e08b01c7503..c716a360db81 100644
--- a/security/zebedee/distinfo
+++ b/security/zebedee/distinfo
@@ -1 +1 @@
-MD5 (zebedee-2.2.2.tar.gz) = 74d33041bcf49b5c49f0e44b6fa0e169
+MD5 (zebedee-2.4.1.tar.gz) = d17a556b966b7b8b1a199b2078e32780
diff --git a/security/zebedee/files/patch-aa b/security/zebedee/files/patch-aa
index 153ee3d6d433..656dbec4298a 100644
--- a/security/zebedee/files/patch-aa
+++ b/security/zebedee/files/patch-aa
@@ -1,68 +1,158 @@
---- Makefile.orig Fri Apr 13 12:41:22 2001
-+++ Makefile Mon Dec 24 17:17:48 2001
-@@ -3,7 +3,7 @@
- #
- # $Id: Makefile,v 1.2 2001/04/13 17:41:21 ndwinton Exp $
-
--OS =
-+OS = freebsd
-
- ###
- ### Locations of tools, libraries and installation directories.
-@@ -12,19 +12,16 @@
-
- # Chose your C compiler
-
--CC_$(OS) = gcc
--
- CC_win32 = c:/gcc-2.95.2/bin/gcc
- CC_linux = gcc -pthread
- CC_solaris = gcc
- CC_freebsd = gcc -pthread
- CC_tru64 = cc
--CC = $(CC_$(OS))
-
- # Optimise/debug compilation
-
- #OPTIM = -Wall -g
--OPTIM = -O3
-+OPTIM =
-
- # Location of gmp include and library
- #
-@@ -36,19 +33,19 @@
-
- # Location of Blowfish include and library
-
--BFINC = -I../blowfish-0.9.5a
--BFLIB = ../blowfish-0.9.5a/libblowfish.a
-+BFINC = -I${OPENSSLINC} -I${OPENSSLINC}/openssl
-+BFLIB = ${OPENSSLLIB}/libcrypto.a
-
- # Location of zlib include and library
-
--ZINC = -I../zlib-1.1.3
--ZLIB = ../zlib-1.1.3/libz.a
-+ZINC =
-+ZLIB = -lz
-
- # Location of bzlib include and library
- # Set these empty if you don't want bzib2 support
-
--BZINC = -I../bzip2-1.0.1
--BZLIB = ../bzip2-1.0.1/libbz2.a
-+BZINC = -I${LOCALBASE}/include
-+BZLIB = -L${LOCALBASE}/lib -lbz2
-
- #
- # Tools needed for Perl "POD"-format documentation conversion.
-@@ -133,7 +130,8 @@
- #### You REALLY shouldn't have to modify anything beyond here ...
- ####
-
--CFLAGS = $(OPTIM) $(DEFINES) -I. $(GMPINC) $(BFINC) $(ZINC) $(BZINC)
-+CFLAGS ?= -O3
-+CFLAGS += ${PTHREAD_LIBS} ${PTHREAD_CFLAGS} $(OPTIM) $(DEFINES) -I. $(GMPINC) $(BFINC) $(ZINC) $(BZINC)
-
- LIBS = $(GMPLIB) $(BFLIB) $(ZLIB) $(BZLIB) $(OSLIBS)
-
+*** Makefile.orig Thu Feb 27 11:48:08 2003
+--- Makefile Thu Feb 27 11:48:13 2003
+***************
+*** 3,23 ****
+ #
+ # $Id: Makefile,v 1.13 2002/05/29 17:42:08 ndwinton Exp $
+
+ ZBD_VERSION = 2.4.1
+
+! OS =
+
+ ###
+ ### Locations of tools, libraries and installation directories.
+ ### You may well need to change these.
+ ###
+
+ # Choose your C compiler
+
+- CC_$(OS) = gcc
+-
+ CC_win32 = c:/msys/1.0/mingw/bin/gcc
+ CC_linux = gcc -pthread
+ CC_solaris = gcc
+ CC_freebsd = gcc -pthread
+ CC_tru64 = cc
+--- 3,21 ----
+ #
+ # $Id: Makefile,v 1.13 2002/05/29 17:42:08 ndwinton Exp $
+
+ ZBD_VERSION = 2.4.1
+
+! OS = freebsd
+
+ ###
+ ### Locations of tools, libraries and installation directories.
+ ### You may well need to change these.
+ ###
+
+ # Choose your C compiler
+
+ CC_win32 = c:/msys/1.0/mingw/bin/gcc
+ CC_linux = gcc -pthread
+ CC_solaris = gcc
+ CC_freebsd = gcc -pthread
+ CC_tru64 = cc
+***************
+*** 28,38 ****
+ CC = $(CC_$(OS))
+
+ # Optimise/debug compilation
+
+ #OPTIM = -Wall -g
+! OPTIM = -O3
+
+ # Location of gmp include and library
+ #
+ # NOTE: These are no longer used unless you define USE_GMP_LIBRARY (which is
+ # undefined by default). Uncomment them as necessary.
+--- 26,36 ----
+ CC = $(CC_$(OS))
+
+ # Optimise/debug compilation
+
+ #OPTIM = -Wall -g
+! OPTIM =
+
+ # Location of gmp include and library
+ #
+ # NOTE: These are no longer used unless you define USE_GMP_LIBRARY (which is
+ # undefined by default). Uncomment them as necessary.
+***************
+*** 43,71 ****
+ # Location of Blowfish include and library
+ # You can use the versions from OpenSSL if you have it installed, as follows:
+ # BFINC = /usr/include/openssl
+ # BFLIB = -lcrypto
+
+! BFINC = -I../blowfish-0.9.5a
+! BFLIB = ../blowfish-0.9.5a/libblowfish.a
+
+ # Location of zlib include and library
+
+! ZINC = -I../zlib-1.1.4
+! ZLIB = ../zlib-1.1.4/libz.a
+
+ # Location of bzlib include and library
+ # Set these empty if you don't want bzib2 support
+
+! BZINC = -I../bzip2-1.0.1
+! BZLIB = ../bzip2-1.0.1/libbz2.a
+
+ #
+ # Tools needed for Perl "POD"-format documentation conversion.
+ #
+ PERL_$(OS) = perl
+ PERL_win32 = c:/perl/bin/perl # Avoid Cygwin port
+ PERL = $(PERL_$(OS))
+
+ BAT_win32 = .bat
+
+ POD2HTML = $(PERL) -S pod2html$(BAT_$(OS))
+--- 41,70 ----
+ # Location of Blowfish include and library
+ # You can use the versions from OpenSSL if you have it installed, as follows:
+ # BFINC = /usr/include/openssl
+ # BFLIB = -lcrypto
+
+! BFINC = -I${OPENSSLINC} -I${OPENSSLINC}/openssl
+! BFLIB = ${OPENSSLLIB}/libcrypto.a
+
+ # Location of zlib include and library
+
+! ZINC =
+! ZLIB = -lz
+
+ # Location of bzlib include and library
+ # Set these empty if you don't want bzib2 support
+
+! BZINC = -I${LOCALBASE}/include
+! BZLIB = -L${LOCALBASE}/lib -lbz2
+
+ #
+ # Tools needed for Perl "POD"-format documentation conversion.
+ #
+ PERL_$(OS) = perl
+ PERL_win32 = c:/perl/bin/perl # Avoid Cygwin port
++ PERL_freebsd = perl
+ PERL = $(PERL_$(OS))
+
+ BAT_win32 = .bat
+
+ POD2HTML = $(PERL) -S pod2html$(BAT_$(OS))
+***************
+*** 173,183 ****
+
+ ####
+ #### You REALLY shouldn't have to modify anything beyond here ...
+ ####
+
+! CFLAGS = $(OPTIM) $(DEFINES) -I. $(GMPINC) $(BFINC) $(ZINC) $(BZINC)
+
+ LIBS = $(GMPLIB) $(BFLIB) $(ZLIB) $(BZLIB) $(OSLIBS)
+
+ OBJS = zebedee.o sha_func.o huge.o $(GETOPTOBJ) $(SERVICEOBJ)
+
+--- 172,183 ----
+
+ ####
+ #### You REALLY shouldn't have to modify anything beyond here ...
+ ####
+
+! CFLAGS ?= -03
+! CFLAGS += ${PTHREAD_LIBS} ${PTHREAD_CFLAGS} $(OPTIM) $(DEFINES) -I. $(GMPINC) $(BFINC) $(ZINC) $(BZINC)
+
+ LIBS = $(GMPLIB) $(BFLIB) $(ZLIB) $(BZLIB) $(OSLIBS)
+
+ OBJS = zebedee.o sha_func.o huge.o $(GETOPTOBJ) $(SERVICEOBJ)
+