aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pinentry-curses/Makefile20
2 files changed, 21 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3a83923fd79c..48aa5da751e2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -309,6 +309,7 @@
SUBDIR += pgpin
SUBDIR += pidentd
SUBDIR += pinentry
+ SUBDIR += pinentry-curses
SUBDIR += pinentry-gtk
SUBDIR += pinentry-qt
SUBDIR += pks
diff --git a/security/pinentry-curses/Makefile b/security/pinentry-curses/Makefile
new file mode 100644
index 000000000000..f29c96851317
--- /dev/null
+++ b/security/pinentry-curses/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: pinentry-curses
+# Date created: 03 May 2004
+# Whom: Michael Nottebrock <lofi@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pinentry
+
+COMMENT= Curses version of the gnupg password dialog
+
+CONFLICTS= pinentry-0.7.1
+
+PINENTRY_CURSES=yes
+
+PKGNAMESUFFIX= -curses
+
+MASTERDIR= ${.CURDIR}/../pinentry
+
+.include "${MASTERDIR}/Makefile"