aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/p5-Authen-Radius/Makefile4
-rw-r--r--security/p5-Crypt-DES/Makefile4
-rw-r--r--security/p5-Crypt-IDEA/Makefile4
-rw-r--r--security/p5-MD5/Makefile4
-rw-r--r--security/p5-PGP-Sign/Makefile4
-rw-r--r--security/p5-PGP/Makefile4
-rw-r--r--security/ssh/Makefile7
-rw-r--r--security/ssh2/Makefile7
8 files changed, 18 insertions, 20 deletions
diff --git a/security/p5-Authen-Radius/Makefile b/security/p5-Authen-Radius/Makefile
index 8e74b16c08e7..2fdec595d691 100644
--- a/security/p5-Authen-Radius/Makefile
+++ b/security/p5-Authen-Radius/Makefile
@@ -3,7 +3,7 @@
# Date created: September 11th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.1.1.1 1997/09/13 17:48:49 jfitz Exp $
+# $Id: Makefile,v 1.2 1998/08/23 15:06:57 jseger Exp $
#
DISTNAME= RadiusPerl-0.05
@@ -24,6 +24,6 @@ pre-configure:
@${CP} ${WRKSRC}/Authen/Radius.pm ${WRKSRC}
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PREFIX}/bin/perl Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-DES/Makefile b/security/p5-Crypt-DES/Makefile
index 6cf8e8d5d89b..efe8fc45d8b0 100644
--- a/security/p5-Crypt-DES/Makefile
+++ b/security/p5-Crypt-DES/Makefile
@@ -3,7 +3,7 @@
# Date created: October 20th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.7 1997/06/24 18:43:08 jfitz Exp $
+# $Id: Makefile,v 1.8 1998/09/03 13:45:44 asami Exp $
#
DISTNAME= Crypt-DES-1.0
@@ -22,6 +22,6 @@ MAN3= Crypt::DES.3
MANPREFIX= ${PREFIX}/lib/perl5
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-IDEA/Makefile b/security/p5-Crypt-IDEA/Makefile
index 99ef5b3870be..5c943634b536 100644
--- a/security/p5-Crypt-IDEA/Makefile
+++ b/security/p5-Crypt-IDEA/Makefile
@@ -3,7 +3,7 @@
# Date created: October 20th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.8 1997/06/24 18:43:09 jfitz Exp $
+# $Id: Makefile,v 1.9 1998/09/03 13:45:44 asami Exp $
#
DISTNAME= Crypt-IDEA-1.0
@@ -22,6 +22,6 @@ MAN3= Crypt::IDEA.3
MANPREFIX= ${PREFIX}/lib/perl5
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>
diff --git a/security/p5-MD5/Makefile b/security/p5-MD5/Makefile
index ab769c780fd9..23a6fe708c0c 100644
--- a/security/p5-MD5/Makefile
+++ b/security/p5-MD5/Makefile
@@ -3,7 +3,7 @@
# Date created: September 30th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.9 1998/08/06 15:10:02 vanilla Exp $
+# $Id: Makefile,v 1.10 1998/08/16 00:48:41 hoek Exp $
#
DISTNAME= MD5-1.7
@@ -20,6 +20,6 @@ MAN3= MD5.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index d60fc597188c..78a1f885a7e7 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -3,7 +3,7 @@
# Date created: January 2, 1998
# Whom: Don Croyle <croyle@gelemna.ft-wayne.in.us>
#
-# $Id: Makefile,v 1.2 1998/08/23 13:32:58 jseger Exp $
+# $Id: Makefile,v 1.3 1998/08/24 00:43:52 steve Exp $
#
DISTNAME= PGP-Sign-0.09
@@ -22,6 +22,6 @@ MAN3= PGP::Sign.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>
diff --git a/security/p5-PGP/Makefile b/security/p5-PGP/Makefile
index a0ed494d78ff..e81fc01ecf5d 100644
--- a/security/p5-PGP/Makefile
+++ b/security/p5-PGP/Makefile
@@ -3,7 +3,7 @@
# Date created: October 21st 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.10 1997/09/18 02:47:42 jfitz Exp $
+# $Id: Makefile,v 1.11 1998/09/03 13:45:47 asami Exp $
#
DISTNAME= PGP-0.3a
@@ -27,6 +27,6 @@ pre-configure:
@${CP} ${WRKSRC}/PGP/Pipe.pm ${WRKSRC}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index d13628771ddb..9ea8172591cb 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.61 1998/08/17 12:12:34 vanilla Exp $
+# $Id: Makefile,v 1.62 1998/08/19 19:51:10 hoek Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
@@ -134,10 +134,9 @@ post-install:
# Following stuff must be after <bsd.port.mk> to expand exists() properly
.if defined(USE_PERL) && ${USE_PERL} == YES || \
- exists(${PREFIX}/bin/perl${PERL_VERSION}) && \
- (!defined(USE_PERL) || ${USE_PERL} != NO)
+ exists(${PERL5}) && (!defined(USE_PERL) || ${USE_PERL} != NO)
BUILD_DEPENDS+= perl${PERL_VERSION}:${PORTSDIR}/lang/perl5
-CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl${PERL_VERSION}
+CONFIGURE_ENV+= PERL=${PERL5}
.else
CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
.endif
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index d13628771ddb..9ea8172591cb 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.61 1998/08/17 12:12:34 vanilla Exp $
+# $Id: Makefile,v 1.62 1998/08/19 19:51:10 hoek Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
@@ -134,10 +134,9 @@ post-install:
# Following stuff must be after <bsd.port.mk> to expand exists() properly
.if defined(USE_PERL) && ${USE_PERL} == YES || \
- exists(${PREFIX}/bin/perl${PERL_VERSION}) && \
- (!defined(USE_PERL) || ${USE_PERL} != NO)
+ exists(${PERL5}) && (!defined(USE_PERL) || ${USE_PERL} != NO)
BUILD_DEPENDS+= perl${PERL_VERSION}:${PORTSDIR}/lang/perl5
-CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl${PERL_VERSION}
+CONFIGURE_ENV+= PERL=${PERL5}
.else
CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
.endif