aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/authforce/Makefile2
-rw-r--r--security/metasploit/Makefile3
-rw-r--r--security/pinentry/Makefile2
3 files changed, 3 insertions, 4 deletions
diff --git a/security/authforce/Makefile b/security/authforce/Makefile
index dfa0bb6d8858..e504b58767d3 100644
--- a/security/authforce/Makefile
+++ b/security/authforce/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
OPTIONS_DEFINE= CURL NLS
-USE_NCURSES= yes
+USES= ncurses
#USE_READLINE= yes
GNU_CONFIGURE= yes
USE_BZIP2= yes
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index ba8e0393f699..1602bed49f94 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -20,11 +20,10 @@ SCRIPTS= msfcli msfconsole msfd msfelfscan msfencode msfmachscan \
OPTIONS_DEFINE= SVN
NO_BUILD= yes
+USES= ncurses:port
USE_RUBY= yes
USE_RUBY_FEATURES= iconv
USE_BZIP2= yes
-USE_NCURSES= yes
-WITH_NCURSES_PORT= yes
.include <bsd.port.pre.mk>
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index bc4880f9a9bb..6864efd4112b 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -78,7 +78,7 @@ PLIST_SUB+= WITH_GTK2="@comment "
.endif
.if ${PORT_OPTIONS:MNCURSES}
-USE_NCURSES= yes
+USES+= ncurses
PLIST_SUB+= WITH_NCURSES=""
.else
CONFIGURE_ARGS+=--disable-pinentry-curses