aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/pam-pgsql/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/security/pam-pgsql/Makefile b/security/pam-pgsql/Makefile
index 1210f997e279..1a82061a7837 100644
--- a/security/pam-pgsql/Makefile
+++ b/security/pam-pgsql/Makefile
@@ -9,18 +9,24 @@ PORTNAME= pam-pgsql
PORTVERSION= 0.3
PORTREVISION= 1
CATEGORIES= security databases
-# When the family of Debian mirrors is added to bsd.port.mk,
-# this will suddenly start making sense:
-MASTER_SITES= http://ftp.debian.org/debian/${MASTER_SITE_SUBDIR}/ \
- ftp://ftp.bora.net/pub/linux/debian/${MASTER_SITE_SUBDIR}/ \
- ${MASTER_SITE_DEBIAN}
-MASTER_SITE_SUBDIR= dists/woody/main/source/admin
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= pool/main/p/pam-pgsql
DISTFILES= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= mi@aldan.algebra.com
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+# When the family of Debian mirrors is added to bsd.port.mk,
+# this will suddenly start making sense:
+MASTER_SITE_DEBIAN?= http://ftp.debian.org/debian/%SUBDIR%/
+# This should help the users of MASTER_SORT_REGEX:
+.for c in at bg br cz de ee es fi fr hu it jp kr nl no nz pl se si tr uk
+MASTER_SITES_DEBIAN+= http://ftp.$c.debian.org/debian/%SUBDIR%/
+.endfor
+MASTER_SITES_DEBIAN+= http://ftp.au.debian.org/pub/debian/%SUBDIR%/ \
+ ftp://ftp.bora.net/pub/linux/debian/%SUBDIR%/
+
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ARGS+= -j 2