aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/hpn-ssh/Makefile4
-rw-r--r--security/openssh-portable/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 1914de5e797b..bbc5d0212829 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
CONFIGURE_ARGS+= --disable-suid-ssh
.endif
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
PORTABLE_SUFFIX=
GSSAPI_SUFFIX= -gssapi
CONFLICTS+= openssh-portable-*
@@ -129,7 +129,7 @@ test:
.include <bsd.port.pre.mk>
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
.if ${OPENSSLBASE} == "/usr"
CONFIGURE_ARGS+= --without-rpath
LDFLAGS=
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 1914de5e797b..bbc5d0212829 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
CONFIGURE_ARGS+= --disable-suid-ssh
.endif
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
PORTABLE_SUFFIX=
GSSAPI_SUFFIX= -gssapi
CONFLICTS+= openssh-portable-*
@@ -129,7 +129,7 @@ test:
.include <bsd.port.pre.mk>
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
.if ${OPENSSLBASE} == "/usr"
CONFIGURE_ARGS+= --without-rpath
LDFLAGS=