aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2-gssapi/Makefile87
-rw-r--r--security/cyrus-sasl2-gssapi/pkg-descr3
-rw-r--r--security/cyrus-sasl2/Makefile18
-rw-r--r--security/cyrus-sasl2/pkg-plist4
4 files changed, 93 insertions, 19 deletions
diff --git a/security/cyrus-sasl2-gssapi/Makefile b/security/cyrus-sasl2-gssapi/Makefile
new file mode 100644
index 000000000000..c2ba3857023d
--- /dev/null
+++ b/security/cyrus-sasl2-gssapi/Makefile
@@ -0,0 +1,87 @@
+# $FreeBSD$
+
+PORTNAME= gssapi
+PORTVERSION= 2.1.26
+#PORTREVISION= 0
+CATEGORIES= security ipv6
+MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-sasl/
+PKGNAMEPREFIX= cyrus-sasl-
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= SASL GSSAPI authentication plugin
+
+LICENSE= BSD4CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+
+CYRUS_SASL2_DIR=${MASTERDIR}/../cyrus-sasl2
+DISTINFO_FILE= ${CYRUS_SASL2_DIR}/distinfo
+PATCHDIR= ${CYRUS_SASL2_DIR}/files
+INSTALL_WRKSRC= ${WRKSRC}/plugins
+
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
+ --with-plugindir=${PREFIX}/lib/sasl2 \
+ --with-dbpath=${PREFIX}/etc/sasldb2 \
+ --with-lib-subdir=lib \
+ --includedir=${PREFIX}/include \
+ --enable-static \
+ --with-rc4=openssl
+CONFIGURE_ARGS+=--with-dblib=none \
+ --disable-anon \
+ --disable-cram \
+ --disable-digest \
+ --disable-krb4 \
+ --disable-ntlm \
+ --disable-otp \
+ --disable-plain \
+ --disable-scram
+
+MAKE_ENV+= INSTALL_STRIP_FLAG=${STRIP}
+
+OPTIONS_SINGLE= KERBEROS
+OPTIONS_SINGLE_KERBEROS=BASE HEIMDAL MIT
+OPTIONS_DEFAULT= BASE
+BASE_DESC= Use Heimdal in base
+BASE_CONFIGURE_ENABLE= gssapi
+HEIMDAL_DESC= Use Heimdal from ports
+HEIMDAL_CONFIGURE_ON= --enable-gssapi=${PREFIX} --with-gss_impl=heimdal
+HEIMDAL_BUILD_DEPENDS= ${PREFIX}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
+HEIMDAL_RUN_DEPENDS= ${HEIMDAL_BUILD_DEPENDS}
+HEIMDAL_LDFLAGS= "-R${PREFIX}/lib"
+MIT_DESC= Use MIT Kerberos V5
+MIT_CONFIGURE_ON= --enable-gssapi=${PREFIX} --with-gss_impl=mit
+MIT_LIB_DEPENDS= libkrb5support.0:${PORTSDIR}/security/krb5
+MIT_LDFLAGS= "-R${PREFIX}/lib"
+
+PLIST_FILES= lib/sasl2/libgssapiv2.a \
+ lib/sasl2/libgssapiv2.la \
+ lib/sasl2/libgssapiv2.so \
+ lib/sasl2/libgssapiv2.so.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MHEIMDAL}
+PLIST_FILES+= lib/sasl2/libgs2.a \
+ lib/sasl2/libgs2.la \
+ lib/sasl2/libgs2.so \
+ lib/sasl2/libgs2.so.3
+.endif
+
+.if ${OPENSSLBASE} == /usr
+CONFIGURE_ARGS+=--with-openssl=yes
+.else
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
+.endif
+
+do-build:
+ cd ${WRKSRC}/include && ${MAKE}
+ cd ${WRKSRC}/plugins && ${MAKE}
+
+.include <bsd.port.post.mk>
diff --git a/security/cyrus-sasl2-gssapi/pkg-descr b/security/cyrus-sasl2-gssapi/pkg-descr
new file mode 100644
index 000000000000..729dbd44f930
--- /dev/null
+++ b/security/cyrus-sasl2-gssapi/pkg-descr
@@ -0,0 +1,3 @@
+SASL GSSAPI authentication plugin
+
+WWW: http://cyrusimap.web.cmu.edu/
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index ff1a0934e879..c41158960ac7 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cyrus-sasl
PORTVERSION= 2.1.26
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-sasl/ \
http://cyrusimap.org/releases/
@@ -10,7 +10,7 @@ MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-sasl/ \
MAINTAINER= ume@FreeBSD.org
COMMENT= RFC 2222 SASL (Simple Authentication and Security Layer)
-LICENSE= BSD
+LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
USES= perl5
@@ -31,6 +31,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-auth-sasldb \
--with-rc4=openssl \
--with-saslauthd=${SASLAUTHD_RUNPATH} \
+ --disable-gssapi \
--disable-krb4
MAKE_ENV+= INSTALL_STRIP_FLAG=${STRIP}
@@ -108,17 +109,6 @@ SQL= "@comment "
.if ${ARCH} == "amd64"
CPPFLAGS+= -fPIC
.endif
-.if !defined(WITHOUT_GSSAPI) && defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.so)
-CONFIGURE_ARGS+=--enable-gssapi=${KRB5_HOME} --with-gss_impl=mit
-LDFLAGS+= "-R${KRB5_HOME}/lib"
-.elif !defined(WITHOUT_GSSAPI) && defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
-CONFIGURE_ARGS+=--enable-gssapi=${HEIMDAL_HOME} --with-gss_impl=heimdal
-.elif !defined(WITHOUT_GSSAPI) && exists(/usr/lib/libkrb5.a)
-CONFIGURE_ARGS+=--enable-gssapi
-.else
-CONFIGURE_ARGS+=--disable-gssapi
-GSSAPI= "@comment "
-.endif
.if ${OPENSSLBASE} == /usr
CONFIGURE_ARGS+=--with-openssl=yes
@@ -148,8 +138,6 @@ HTDOCS= advanced appconvert components gssapi index install macosx \
windows
PLIST_SUB+= PREFIX=${PREFIX} \
- GSSAPI=${GSSAPI} \
- EBONES=${EBONES} \
SQL=${SQL} \
DOCSDIR=${DOCSDIR:S/^${PREFIX}\///}
diff --git a/security/cyrus-sasl2/pkg-plist b/security/cyrus-sasl2/pkg-plist
index 064437fce559..b963ae109596 100644
--- a/security/cyrus-sasl2/pkg-plist
+++ b/security/cyrus-sasl2/pkg-plist
@@ -22,10 +22,6 @@ lib/sasl2/libanonymous.so.3
%%DIGEST%%lib/sasl2/libdigestmd5.la
%%DIGEST%%lib/sasl2/libdigestmd5.so
%%DIGEST%%lib/sasl2/libdigestmd5.so.3
-%%GSSAPI%%lib/sasl2/libgssapiv2.a
-%%GSSAPI%%lib/sasl2/libgssapiv2.la
-%%GSSAPI%%lib/sasl2/libgssapiv2.so
-%%GSSAPI%%lib/sasl2/libgssapiv2.so.3
%%LOGIN%%lib/sasl2/liblogin.a
%%LOGIN%%lib/sasl2/liblogin.la
%%LOGIN%%lib/sasl2/liblogin.so