aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/apache-xml-security-c/Makefile2
-rw-r--r--security/beecrypt/Makefile2
-rw-r--r--security/bioapi/Makefile2
-rw-r--r--security/borzoi/Makefile2
-rw-r--r--security/courier-authlib/Makefile2
-rw-r--r--security/cryptplug/Makefile2
-rw-r--r--security/cvm/Makefile2
-rw-r--r--security/cyrus-sasl2-ldapdb/Makefile2
-rw-r--r--security/cyrus-sasl2/Makefile2
-rw-r--r--security/distcache-devel/Makefile2
-rw-r--r--security/distcache/Makefile2
-rw-r--r--security/engine_pkcs11/Makefile2
-rw-r--r--security/fakeroot/Makefile2
-rw-r--r--security/gnome-keyring/Makefile2
-rw-r--r--security/gnutls-devel/Makefile2
-rw-r--r--security/gnutls/Makefile2
-rw-r--r--security/gpgme/Makefile2
-rw-r--r--security/gpgme03/Makefile2
-rw-r--r--security/heimdal/Makefile2
-rw-r--r--security/ipsec-tools/Makefile2
-rw-r--r--security/kgpg/Makefile2
-rw-r--r--security/klamav/Makefile6
-rw-r--r--security/kopete-otr/Makefile2
-rw-r--r--security/kovpn/Makefile2
-rw-r--r--security/krb5-16/Makefile4
-rw-r--r--security/krb5-16/files/patch-config::shlib.conf13
-rw-r--r--security/krb5/Makefile4
-rw-r--r--security/krb5/files/patch-config::shlib.conf13
-rw-r--r--security/kssh/Makefile2
-rw-r--r--security/libgcrypt/Makefile2
-rw-r--r--security/libgnomesu/Makefile2
-rw-r--r--security/libgpg-error/Makefile2
-rw-r--r--security/libgringotts/Makefile2
-rw-r--r--security/libident/Makefile2
-rw-r--r--security/libmcrypt/Makefile2
-rw-r--r--security/libntlm/Makefile2
-rw-r--r--security/libotr/Makefile2
-rw-r--r--security/libp11/Makefile3
-rw-r--r--security/nessus-libnasl/Makefile2
-rw-r--r--security/nessus-libraries/Makefile2
-rw-r--r--security/opencdk/Makefile2
-rw-r--r--security/openct/Makefile3
-rw-r--r--security/opensaml/Makefile2
-rw-r--r--security/opensc/Makefile3
-rw-r--r--security/openscep/Makefile2
-rw-r--r--security/pam-mysql/Makefile2
-rw-r--r--security/pam_authsrv/Makefile2
-rw-r--r--security/pam_p11/Makefile2
-rw-r--r--security/pam_per_user/Makefile2
-rw-r--r--security/pam_pseudo/Makefile2
-rw-r--r--security/shishi/Makefile2
-rw-r--r--security/snort/Makefile2
-rw-r--r--security/steghide/Makefile2
-rw-r--r--security/stunnel/Makefile2
-rw-r--r--security/tor-devel/Makefile2
55 files changed, 70 insertions, 73 deletions
diff --git a/security/apache-xml-security-c/Makefile b/security/apache-xml-security-c/Makefile
index c461ab849394..0471a4a2296b 100644
--- a/security/apache-xml-security-c/Makefile
+++ b/security/apache-xml-security-c/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS+= xerces-c.27:${PORTSDIR}/textproc/xerces-c2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-xerces=${LOCALBASE}
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/security/beecrypt/Makefile b/security/beecrypt/Makefile
index 70a7a254bbdb..ba190f3b9f73 100644
--- a/security/beecrypt/Makefile
+++ b/security/beecrypt/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= BeeCrypt is an open source cryptography library
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/bioapi/Makefile b/security/bioapi/Makefile
index b8d592856532..b14f3aa5733e 100644
--- a/security/bioapi/Makefile
+++ b/security/bioapi/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://www.qrivy.net/~michael/blua/bioapi/ \
MAINTAINER= fli@shapeshifter.se
COMMENT= BioAPI library implementation
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
GNU_CONFIGURE= yes
# Problems reported with higher optimization levels
diff --git a/security/borzoi/Makefile b/security/borzoi/Makefile
index 4509f60219cd..348fb4e625a1 100644
--- a/security/borzoi/Makefile
+++ b/security/borzoi/Makefile
@@ -18,7 +18,7 @@ COMMENT= An Elliptic Curve Cryptography Library
BUILD_DEPENDS= ${LOCALBASE}/lib/libntl.a:${PORTSDIR}/math/ntl
RUN_DEPENDS= ${LOCALBASE}/lib/libntl.a:${PORTSDIR}/math/ntl
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/courier-authlib/Makefile b/security/courier-authlib/Makefile
index 40ce6cc5ec65..19373e9ec4be 100644
--- a/security/courier-authlib/Makefile
+++ b/security/courier-authlib/Makefile
@@ -34,7 +34,7 @@ OPTIONS+= GDBM "Use gdbm instead of system bdb" off
.else # !defined(PKGNAMESUFFIX)
-USE_AUTOTOOLS= libltdl:15
+USE_AUTOTOOLS= libltdl:22
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/security/cryptplug/Makefile b/security/cryptplug/Makefile
index 81966cef158e..b28514ae9ad0 100644
--- a/security/cryptplug/Makefile
+++ b/security/cryptplug/Makefile
@@ -18,7 +18,7 @@ COMMENT= A collection of plug-ins to cryptographic engines
BUILD_DEPENDS= ${LOCALBASE}/lib/libgpgme03.so.9:${PORTSDIR}/security/gpgme03 \
gpg-agent:${PORTSDIR}/security/gnupg
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/security/cvm/Makefile b/security/cvm/Makefile
index 6cbd4a626ffe..4f1a7f967abb 100644
--- a/security/cvm/Makefile
+++ b/security/cvm/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= bg.2:${PORTSDIR}/devel/bglibs
CONFLICTS= bglibs-1.00*
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
LIBTOOLFILES= #none
USE_LDCONFIG= yes
LDFLAGS?= -s
diff --git a/security/cyrus-sasl2-ldapdb/Makefile b/security/cyrus-sasl2-ldapdb/Makefile
index 0e38f793f669..97a52f55f9f8 100644
--- a/security/cyrus-sasl2-ldapdb/Makefile
+++ b/security/cyrus-sasl2-ldapdb/Makefile
@@ -28,7 +28,7 @@ INSTALL_WRKSRC= ${WRKDIR}/${DISTNAME}/plugins
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_OPENSSL= yes
GNU_CONFIGURE= yes
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index e5ee41ccfde1..1852e3123977 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -19,7 +19,7 @@ COMMENT= RFC 2222 SASL (Simple Authentication and Security Layer)
LATEST_LINK= ${PORTNAME}2
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}2
diff --git a/security/distcache-devel/Makefile b/security/distcache-devel/Makefile
index b82f0d35e6d1..f5db40fbe952 100644
--- a/security/distcache-devel/Makefile
+++ b/security/distcache-devel/Makefile
@@ -22,7 +22,7 @@ CONFLICTS= distcache-1.4*
USE_BZIP2= yes
USE_RC_SUBR= dc_server.sh
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_OPENSSL= yes
LIBTOOLFILES= configure ssl/configure
USE_LDCONFIG= yes
diff --git a/security/distcache/Makefile b/security/distcache/Makefile
index f54af1346a95..de887a7143ab 100644
--- a/security/distcache/Makefile
+++ b/security/distcache/Makefile
@@ -20,7 +20,7 @@ CONFLICTS= distcache-devel-*
USE_BZIP2= yes
USE_RC_SUBR= dc_server.sh
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_OPENSSL= yes
USE_LDCONFIG= yes
diff --git a/security/engine_pkcs11/Makefile b/security/engine_pkcs11/Makefile
index 17374b219d5c..eacc02afde65 100644
--- a/security/engine_pkcs11/Makefile
+++ b/security/engine_pkcs11/Makefile
@@ -15,7 +15,7 @@ COMMENT= An implementation of a PKCS\#11 engine for OpenSSL
LIB_DEPENDS= p11.3:${PORTSDIR}/security/libp11
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
diff --git a/security/fakeroot/Makefile b/security/fakeroot/Makefile
index 7e17d31cf89a..96cb74dafe7c 100644
--- a/security/fakeroot/Makefile
+++ b/security/fakeroot/Makefile
@@ -17,7 +17,7 @@ COMMENT= Simulate the root user behaviour
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ipc=tcp
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
index 150b78ef1ede..ae3f961f4f49 100644
--- a/security/gnome-keyring/Makefile
+++ b/security/gnome-keyring/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix gtk20 ltverhack intlhack gconf2
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-pam-dir="${PREFIX}/lib"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index d368a16bfca8..0cb462516aac 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -24,7 +24,7 @@ USE_ICONV= yes
USE_GNOME= pkgconfig ltverhack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -fPIC" LDFLAGS="${LDFLAGS}"
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 4ab56b76f9a2..6bf98983cb3d 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -26,7 +26,7 @@ USE_GNOME= pkgconfig ltverhack
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -fPIC" LDFLAGS="${LDFLAGS}"
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index d1e5c9433e55..670c5c8b6a0f 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -19,7 +19,7 @@ COMMENT= A library to make access to GnuPG easier
LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/security/gpgme03/Makefile b/security/gpgme03/Makefile
index 110de3fda8f8..dc766c581f85 100644
--- a/security/gpgme03/Makefile
+++ b/security/gpgme03/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= pth.20:${PORTSDIR}/devel/pth
LATEST_LINK= gpgme03
-USE_AUTOTOOLS= autoconf:262 libtool:15
+USE_AUTOTOOLS= autoconf:262 libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index c455c7800cdf..fb4912501989 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -22,7 +22,7 @@ OPTIONS+= LDAP "Use OpenLDAP as the KDC backend" off
OPTIONS+= CRACKLIB "Use CrackLib for password quality checking" off
OPTIONS+= X11 "Build X11 utilies" off
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 9039cee88f59..828610c330a2 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -23,7 +23,7 @@ USE_RC_SUBR= racoon.sh
USE_OPENSSL= yes
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-shared --sysconfdir=${PREFIX}/etc/racoon \
diff --git a/security/kgpg/Makefile b/security/kgpg/Makefile
index 6503dd8c24f4..e63ec54ee084 100644
--- a/security/kgpg/Makefile
+++ b/security/kgpg/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
CONFLICTS= kdeutils-3.[2-6].*
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_KDELIBS_VER= 3
post-patch:
diff --git a/security/klamav/Makefile b/security/klamav/Makefile
index cf8e4910a220..ada48b54ff93 100644
--- a/security/klamav/Makefile
+++ b/security/klamav/Makefile
@@ -27,8 +27,8 @@ USE_GNOME= pkgconfig
USE_GETTEXT= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15 aclocal:19
-
+USE_AUTOTOOLS= libtool:22 aclocal:19
+LIBTOOLFILES= acinclude.m4 configure
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS} -lintl -L${PREFIX}/lib"
CONFIGURE_ARGS+=--with-qt-dir=${QT_PREFIX} \
--without-included-sqlite
@@ -40,6 +40,6 @@ USE_KDELIBS_VER= 3
pre-configure:
@${CP} ${LTMAIN} ${WRKSRC}/admin
@${CP} ${LIBTOOL_M4} ${WRKSRC}/admin
- @${CP} ${PREFIX}/include/clamav-config.h ${WRKSRC}/src/klamd
+ @${CP} ${LOCALBASE}/include/clamav-config.h ${WRKSRC}/src/klamd
.include <bsd.port.post.mk>
diff --git a/security/kopete-otr/Makefile b/security/kopete-otr/Makefile
index 8012be95e8fb..5d6d8c2c20b8 100644
--- a/security/kopete-otr/Makefile
+++ b/security/kopete-otr/Makefile
@@ -25,7 +25,7 @@ USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/kovpn/Makefile b/security/kovpn/Makefile
index bad51b97e696..d371cb11ca85 100644
--- a/security/kovpn/Makefile
+++ b/security/kovpn/Makefile
@@ -27,7 +27,7 @@ INSTALLS_ICONS= yes
USE_GMAKE= yes
USE_XORG= xpm
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:15:env
+USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:22
.include <bsd.port.pre.mk>
diff --git a/security/krb5-16/Makefile b/security/krb5-16/Makefile
index 10f8cdaec16f..c132c0249ae9 100644
--- a/security/krb5-16/Makefile
+++ b/security/krb5-16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.6.3
-PORTREVISION= 6
+PORTREVISION= 6
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/krb5/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
PATCH_SITES= http://web.mit.edu/kerberos/advisories/
@@ -30,7 +30,7 @@ WITH_OPENSSL_PORT= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --enable-shared
# CONFIGURE_ARGS+= --disable-thread-support
CONFIGURE_ENV= INSTALL="${INSTALL}" YACC=/usr/bin/yacc \
diff --git a/security/krb5-16/files/patch-config::shlib.conf b/security/krb5-16/files/patch-config::shlib.conf
index 18f91fffc6d5..5d680b5487ca 100644
--- a/security/krb5-16/files/patch-config::shlib.conf
+++ b/security/krb5-16/files/patch-config::shlib.conf
@@ -1,6 +1,6 @@
---- config/shlib.conf.orig Mon Oct 23 05:20:11 2006
-+++ config/shlib.conf Wed Mar 28 17:17:55 2007
-@@ -258,22 +258,15 @@
+--- config/shlib.conf.orig 2009-07-13 14:48:25.000000000 +0200
++++ config/shlib.conf 2009-07-13 14:49:49.000000000 +0200
+@@ -258,19 +258,13 @@
;;
*-*-freebsd*)
@@ -16,15 +16,12 @@
+ *) PICFLAGS=-fpic;;
+ esac
SHLIBVEXT='.so.$(LIBMAJOR)'
-+ LDCOMBINE="libtool --mode=link cc -shared"
RPATH_FLAG='-Wl,-rpath -Wl,'
- else
- RPATH_FLAG=-R
- SHLIBVEXT='.so.$(LIBMAJOR).$(LIBMINOR)'
- fi
++
CC_LINK_SHARED='$(CC) $(PROG_LIBPATH) $(RPATH_FLAG)$(PROG_RPATH) $(CFLAGS) $(LDFLAGS)'
SHLIBEXT=.so
-- LDCOMBINE='ld -Bshareable'
- SHLIB_EXPFLAGS='-R$(SHLIB_RDIRS) $(SHLIB_DIRS) $(SHLIB_EXPLIBS)'
- CC_LINK_STATIC='$(CC) $(PROG_LIBPATH) $(CFLAGS) $(LDFLAGS)'
- RUN_ENV='LD_LIBRARY_PATH=`echo $(PROG_LIBPATH) | sed -e "s/-L//g" -e "s/ /:/g"`; export LD_LIBRARY_PATH;'
+ LDCOMBINE='ld -Bshareable'
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index 10f8cdaec16f..c132c0249ae9 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.6.3
-PORTREVISION= 6
+PORTREVISION= 6
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/krb5/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
PATCH_SITES= http://web.mit.edu/kerberos/advisories/
@@ -30,7 +30,7 @@ WITH_OPENSSL_PORT= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --enable-shared
# CONFIGURE_ARGS+= --disable-thread-support
CONFIGURE_ENV= INSTALL="${INSTALL}" YACC=/usr/bin/yacc \
diff --git a/security/krb5/files/patch-config::shlib.conf b/security/krb5/files/patch-config::shlib.conf
index 18f91fffc6d5..5d680b5487ca 100644
--- a/security/krb5/files/patch-config::shlib.conf
+++ b/security/krb5/files/patch-config::shlib.conf
@@ -1,6 +1,6 @@
---- config/shlib.conf.orig Mon Oct 23 05:20:11 2006
-+++ config/shlib.conf Wed Mar 28 17:17:55 2007
-@@ -258,22 +258,15 @@
+--- config/shlib.conf.orig 2009-07-13 14:48:25.000000000 +0200
++++ config/shlib.conf 2009-07-13 14:49:49.000000000 +0200
+@@ -258,19 +258,13 @@
;;
*-*-freebsd*)
@@ -16,15 +16,12 @@
+ *) PICFLAGS=-fpic;;
+ esac
SHLIBVEXT='.so.$(LIBMAJOR)'
-+ LDCOMBINE="libtool --mode=link cc -shared"
RPATH_FLAG='-Wl,-rpath -Wl,'
- else
- RPATH_FLAG=-R
- SHLIBVEXT='.so.$(LIBMAJOR).$(LIBMINOR)'
- fi
++
CC_LINK_SHARED='$(CC) $(PROG_LIBPATH) $(RPATH_FLAG)$(PROG_RPATH) $(CFLAGS) $(LDFLAGS)'
SHLIBEXT=.so
-- LDCOMBINE='ld -Bshareable'
- SHLIB_EXPFLAGS='-R$(SHLIB_RDIRS) $(SHLIB_DIRS) $(SHLIB_EXPLIBS)'
- CC_LINK_STATIC='$(CC) $(PROG_LIBPATH) $(CFLAGS) $(LDFLAGS)'
- RUN_ENV='LD_LIBRARY_PATH=`echo $(PROG_LIBPATH) | sed -e "s/-L//g" -e "s/ /:/g"`; export LD_LIBRARY_PATH;'
+ LDCOMBINE='ld -Bshareable'
diff --git a/security/kssh/Makefile b/security/kssh/Makefile
index 28085e305f86..5eb0899efa85 100644
--- a/security/kssh/Makefile
+++ b/security/kssh/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= kevlo@FreeBSD.org
COMMENT= KDE frontend to ssh
USE_KDELIBS_VER=3
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index e801a6abccbf..f2b1a7539f7e 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -16,7 +16,7 @@ COMMENT= General purpose crypto library based on code used in GnuPG
LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
USE_LDCONFIG= yes
diff --git a/security/libgnomesu/Makefile b/security/libgnomesu/Makefile
index 87ca059d9961..8f0ce6282dfc 100644
--- a/security/libgnomesu/Makefile
+++ b/security/libgnomesu/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://members.chello.nl/~h.lai/libgnomesu/
MAINTAINER= ports@FreeBSD.org
COMMENT= Library and frontend for running commands as root
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui
CONFIGURE_ARGS+=--disable-install-pam
diff --git a/security/libgpg-error/Makefile b/security/libgpg-error/Makefile
index 97d2d1cfbbbe..2a5e2f01bd37 100644
--- a/security/libgpg-error/Makefile
+++ b/security/libgpg-error/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= novel@FreeBSD.org
COMMENT= Common error values for all GnuPG components
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GNOME= ltverhack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/security/libgringotts/Makefile b/security/libgringotts/Makefile
index 6516cadd0c84..7fe45e29f5bb 100644
--- a/security/libgringotts/Makefile
+++ b/security/libgringotts/Makefile
@@ -17,7 +17,7 @@ COMMENT= Library for encapsulating/safekeeping data in encrypted/compressed form
LIB_DEPENDS= mcrypt.8:${PORTSDIR}/security/libmcrypt \
mhash.2:${PORTSDIR}/security/mhash
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
diff --git a/security/libident/Makefile b/security/libident/Makefile
index bb2f39c9b8e1..23abc6e281bf 100644
--- a/security/libident/Makefile
+++ b/security/libident/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.remlab.net/files/libident/
MAINTAINER= ports@FreeBSD.org
COMMENT= A small library to interface the ident protocol server (rfc1413)
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GNOME= gnometarget lthack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/libmcrypt/Makefile b/security/libmcrypt/Makefile
index 69d9451e80e8..7a331e8d7f26 100644
--- a/security/libmcrypt/Makefile
+++ b/security/libmcrypt/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/lib//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Multi-cipher cryptographic library (used in PHP)
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ARGS= --enable-static
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
diff --git a/security/libntlm/Makefile b/security/libntlm/Makefile
index 8cb7d7b2fcba..19a8b9f8eed2 100644
--- a/security/libntlm/Makefile
+++ b/security/libntlm/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= jochen@daten-chaos.de
COMMENT= A library that implement Microsoft's NTLM authentication
USE_GNOME= gnomehack gnometarget pkgconfig
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/security/libotr/Makefile b/security/libotr/Makefile
index bae1ed521c15..7401716c7d00 100644
--- a/security/libotr/Makefile
+++ b/security/libotr/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error \
MAKE_JOBS_SAFE= yes
USE_GNOME= pkgconfig
-USE_AUTOTOOLS= autoconf:262 libtool:15
+USE_AUTOTOOLS= autoconf:262 libtool:22
USE_LDCONFIG= yes
MAN1= otr_toolkit.1
diff --git a/security/libp11/Makefile b/security/libp11/Makefile
index a2957a09daf2..f0f9f761c7f0 100644
--- a/security/libp11/Makefile
+++ b/security/libp11/Makefile
@@ -7,13 +7,14 @@
PORTNAME= libp11
PORTVERSION= 0.2.5
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/
MAINTAINER= ale@FreeBSD.org
COMMENT= A small layer on top of PKCS\#11 API
-USE_AUTOTOOLS= libltdl:15
+USE_AUTOTOOLS= libltdl:22
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
diff --git a/security/nessus-libnasl/Makefile b/security/nessus-libnasl/Makefile
index 32a6578c1cca..054d756126a7 100644
--- a/security/nessus-libnasl/Makefile
+++ b/security/nessus-libnasl/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= nessus.4:${PORTSDIR}/security/nessus-libraries
DIST_SUBDIR= nessus
WRKSRC= ${WRKDIR}/libnasl
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_BISON= build
GNU_CONFIGURE= yes
USE_LDCONFIG= YES
diff --git a/security/nessus-libraries/Makefile b/security/nessus-libraries/Makefile
index 2f724e88a060..a6007e40f8fa 100644
--- a/security/nessus-libraries/Makefile
+++ b/security/nessus-libraries/Makefile
@@ -26,7 +26,7 @@ DIST_SUBDIR= nessus
WRKSRC= ${WRKDIR}/nessus-libraries
USE_BISON= build
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ARGS= --enable-cipher
.if defined(WITH_NESSUS_BPF_SHARE)
CONFIGURE_ARGS+= --enable-bpf-sharing
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index 1ada37478f24..541e6e9291b2 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig ltverhack
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
DOCS= AUTHORS NEWS README THANKS doc/opencdk-api.html
diff --git a/security/openct/Makefile b/security/openct/Makefile
index a09f1aa20df3..62672b11d879 100644
--- a/security/openct/Makefile
+++ b/security/openct/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openct
PORTVERSION= 0.6.17
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
http://www.opensc-project.org/files/${PORTNAME}/testing/
@@ -16,7 +17,7 @@ COMMENT= A middleware framework for smart card terminals
OPTIONS= PCSC "Enable PC/SC support" off
-USE_AUTOTOOLS= libltdl:15
+USE_AUTOTOOLS= libltdl:22
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
diff --git a/security/opensaml/Makefile b/security/opensaml/Makefile
index 23da408169cc..01b9d0b55e96 100644
--- a/security/opensaml/Makefile
+++ b/security/opensaml/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl \
xml-security-c.14:${PORTSDIR}/security/apache-xml-security-c
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index bac4a7aa3c21..067aa0dc0e38 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opensc
PORTVERSION= 0.11.9
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
http://www.opensc-project.org/files/${PORTNAME}/testing/
@@ -18,7 +19,7 @@ OPTIONS= OPENCT "Enable direct OpenCT backend support" on \
PCSC "Enable PC/SC backend support" off \
SIGNER "Enable signer browser plugin" off
-USE_AUTOTOOLS= libltdl:15
+USE_AUTOTOOLS= libltdl:22
USE_ICONV= yes
USE_OPENSSL= yes
USE_GMAKE= yes
diff --git a/security/openscep/Makefile b/security/openscep/Makefile
index 5f2ce3a48624..10cf2e16b05d 100644
--- a/security/openscep/Makefile
+++ b/security/openscep/Makefile
@@ -16,7 +16,7 @@ COMMENT= Open source scep server
MAKE_JOBS_SAFE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_OPENSSL= yes
USE_OPENLDAP= yes
USE_APACHE= 1.3+
diff --git a/security/pam-mysql/Makefile b/security/pam-mysql/Makefile
index 4e3216382e0b..7a623dc91e1e 100644
--- a/security/pam-mysql/Makefile
+++ b/security/pam-mysql/Makefile
@@ -17,7 +17,7 @@ COMMENT= A pam module for authenticating with MySQL
USE_MYSQL= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= aclocal:14 autoconf:262 libtool:15
+USE_AUTOTOOLS= aclocal:14 autoconf:262 libtool:22
ACLOCAL_ARGS= -I ${PREFIX}/share/aclocal
CONFIGURE_ARGS= --with-mysql=${LOCALBASE} --with-pam-mods-dir=${PREFIX}/lib --with-pam=/usr
diff --git a/security/pam_authsrv/Makefile b/security/pam_authsrv/Makefile
index a0d9babef6a0..e627417083cd 100644
--- a/security/pam_authsrv/Makefile
+++ b/security/pam_authsrv/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/security/fwtk:build
RESTRICTED= No form of redistribution is allowed, because of linkging against fwtk
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${PORTSDIR}/security/fwtk/work/fwtk" \
CFLAGS="${CFLAGS} -I${PORTSDIR}/security/fwtk/work/fwtk"
CONFIGURE_ARGS= --disable-encap --disable-epkg-install
diff --git a/security/pam_p11/Makefile b/security/pam_p11/Makefile
index 3443ed9bd956..79d920da44f7 100644
--- a/security/pam_p11/Makefile
+++ b/security/pam_p11/Makefile
@@ -16,7 +16,7 @@ COMMENT= A PAM module using crypto tokens for auth
LIB_DEPENDS= p11.3:${PORTSDIR}/security/libp11
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
diff --git a/security/pam_per_user/Makefile b/security/pam_per_user/Makefile
index 3f324f83eca9..013ad17b9ff3 100644
--- a/security/pam_per_user/Makefile
+++ b/security/pam_per_user/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= ftp://ftp.feep.net/pub/software/PAM/pam_per_user/
MAINTAINER= pirzyk@FreeBSD.org
COMMENT= PAM module for per-user authentication
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
MAN5= pam_per_user.5
diff --git a/security/pam_pseudo/Makefile b/security/pam_pseudo/Makefile
index 66ba277253d7..2ee118366e3d 100644
--- a/security/pam_pseudo/Makefile
+++ b/security/pam_pseudo/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.feep.net/pub/software/PAM/pam_pseudo/
MAINTAINER= pirzyk@FreeBSD.org
COMMENT= PAM module for per-user authentication
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ARGS= --disable-encap --disable-epkg-install
INSTALL_TARGET= install-real
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index a475176ad539..2ec33864b6d3 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= idn.16:${PORTSDIR}/dns/libidn \
tasn1.4:${PORTSDIR}/security/libtasn1 \
gcrypt.16:${PORTSDIR}/security/libgcrypt
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_PERL5_BUILD= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_ICONV= yes
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 73f3f1a3bcae..28608878c2ce 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -58,7 +58,7 @@ LIBNET_LIBDIR= ${LIBNET_LIBS:M-L*:S/-L//}
.endif
.if !defined(WITHOUT_DYNAMIC)
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
CONFIGURE_ARGS+= --enable-dynamicplugin
PLIST_SUB+= DYNAMIC=""
diff --git a/security/steghide/Makefile b/security/steghide/Makefile
index 1c62f4199a09..c9fec5c40593 100644
--- a/security/steghide/Makefile
+++ b/security/steghide/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= mcrypt.8:${PORTSDIR}/security/libmcrypt \
USE_GETTEXT= yes
USE_PERL5= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include -fpermissive" \
LIBS="-L${LOCALBASE}/lib -lintl -lmcrypt"
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 8c4097be25ce..ce93d8426ca2 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -16,7 +16,7 @@ MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
MAINTAINER= roam@FreeBSD.org
COMMENT= SSL encryption wrapper for standard network daemons
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_OPENSSL= YES
USE_RC_SUBR= stunnel
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index 446e58a4d865..49941f6a353d 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -20,7 +20,7 @@ COMMENT= An anonymizing overlay network for TCP
RUN_DEPENDS= tsocks:${PORTSDIR}/net/tsocks
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
-USE_AUTOTOOLS= libtool:15 aclocal:110 autoconf:262
+USE_AUTOTOOLS= libtool:22 aclocal:110 autoconf:262
GNU_CONFIGURE= yes
USE_OPENSSL= yes