aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/bioapi/Makefile4
-rw-r--r--security/bioapi/files/patch-addins-dal-mds-dal_classes.h11
2 files changed, 14 insertions, 1 deletions
diff --git a/security/bioapi/Makefile b/security/bioapi/Makefile
index 40da025fb5cf..1962c91a1059 100644
--- a/security/bioapi/Makefile
+++ b/security/bioapi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bioapi
PORTVERSION= 1.2.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= http://www.qrivy.net/~michael/blua/bioapi/ \
http://shapeshifter.se/pub/bioapi/
@@ -17,6 +17,8 @@ COMMENT= BioAPI library implementation
USE_BZIP2= yes
GNU_CONFIGURE= yes
+# Problems reported with higher optimization levels
+CONFIGURE_ENV=CFLAGS="${CFLAGS} -O"
CONFIGURE_ARGS= --localstatedir=/var/db/ --with-Qt-dir=no
INSTALLS_SHLIB= yes
diff --git a/security/bioapi/files/patch-addins-dal-mds-dal_classes.h b/security/bioapi/files/patch-addins-dal-mds-dal_classes.h
new file mode 100644
index 000000000000..999b04bb9b64
--- /dev/null
+++ b/security/bioapi/files/patch-addins-dal-mds-dal_classes.h
@@ -0,0 +1,11 @@
+--- addins/dl/mds/dal_classes.h.orig Fri Jun 10 02:35:44 2005
++++ addins/dl/mds/dal_classes.h Mon Jan 8 01:10:51 2007
+@@ -455,7 +455,7 @@
+ DAL_DATABASE_INFO_REF_PTR &prefDatabase,
+ PORT_MUTEX_HANDLE &Mutex);
+
+- CSSM_RETURN DAL_DATABASE_INFO_LIST::GetDBNamesAndParameters(
++ CSSM_RETURN GetDBNamesAndParameters(
+ CSSM_DL_DB_HANDLE DLDBHandle,
+ DAL_DB_OPEN_PARAM_PTR pParam);
+ };