aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/isnprober/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/security/isnprober/Makefile b/security/isnprober/Makefile
index 2d8b96b06d15..0def7f90812f 100644
--- a/security/isnprober/Makefile
+++ b/security/isnprober/Makefile
@@ -17,16 +17,17 @@ RUN_DEPENDS= p5-Net-RawIP>=0:${PORTSDIR}/net/p5-Net-RawIP
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
NO_BUILD= yes
-NO_STAGE= yes
+SHEBANG_FILES= isnprober
+
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-.ifndef NOPORTDOCS
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>