aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/gnutls-devel/Makefile38
-rw-r--r--security/gnutls-devel/distinfo1
-rw-r--r--security/gnutls-devel/pkg-comment1
-rw-r--r--security/gnutls-devel/pkg-descr17
-rw-r--r--security/gnutls-devel/pkg-plist27
-rw-r--r--security/gnutls/Makefile38
-rw-r--r--security/gnutls/distinfo1
-rw-r--r--security/gnutls/pkg-comment1
-rw-r--r--security/gnutls/pkg-descr17
-rw-r--r--security/gnutls/pkg-plist27
11 files changed, 169 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8acbd06ae5e6..75966a3912c4 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -67,6 +67,7 @@
SUBDIR += geheimnis
SUBDIR += gnupg
SUBDIR += gnupg-idea
+ SUBDIR += gnutls
SUBDIR += gpa
SUBDIR += gpasman
SUBDIR += gpgme
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
new file mode 100644
index 000000000000..b1e6a1a78d66
--- /dev/null
+++ b/security/gnutls-devel/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gnutls
+# Date created: 13 Nov 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnutls
+PORTVERSION= 0.5.11
+CATEGORIES= security net
+MASTER_SITES= ftp://ftp.gnutls.org/pub/gnutls/ \
+ ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/ \
+ http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
+ ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/ \
+
+MAINTAINER= sergei@kolobov.com
+
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
+ tasn1:${PORTSDIR}/security/libtasn1
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+DOCS= AUTHORS NEWS README THANKS
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/tex/*.ps ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/gnutls-devel/distinfo b/security/gnutls-devel/distinfo
new file mode 100644
index 000000000000..35b3aaddb42c
--- /dev/null
+++ b/security/gnutls-devel/distinfo
@@ -0,0 +1 @@
+MD5 (gnutls-0.5.11.tar.gz) = 9e86b8fb85be918a17c6734391de103f
diff --git a/security/gnutls-devel/pkg-comment b/security/gnutls-devel/pkg-comment
new file mode 100644
index 000000000000..2436d4683c53
--- /dev/null
+++ b/security/gnutls-devel/pkg-comment
@@ -0,0 +1 @@
+GNU Transport Layer Security library
diff --git a/security/gnutls-devel/pkg-descr b/security/gnutls-devel/pkg-descr
new file mode 100644
index 000000000000..eb3b18b04920
--- /dev/null
+++ b/security/gnutls-devel/pkg-descr
@@ -0,0 +1,17 @@
+GnuTLS is a portable ANSI C based library which implements the TLS 1.0 and
+SSL 3.0 protocols. The library does not include any patented algorithms and
+is available under the GNU Lesser GPL license.
+
+Important features of the GnuTLS library include:
+- Thread safety
+- Support for both TLS 1.0 and SSL 3.0 protocols
+- Support for both X.509 and OpenPGP certificates
+- Support for basic parsing and verification of certificates
+- Support for SRP for TLS authentication
+- Support for TLS Extension mechanism
+- Support for TLS Compression Methods
+
+Additionaly GnuTLS provides an emulation API for the widely used
+OpenSSL library, to ease integration with existing applications.
+
+WWW: http://www.gnutls.org/
diff --git a/security/gnutls-devel/pkg-plist b/security/gnutls-devel/pkg-plist
new file mode 100644
index 000000000000..8e7a4c6ab718
--- /dev/null
+++ b/security/gnutls-devel/pkg-plist
@@ -0,0 +1,27 @@
+bin/libgnutls-config
+bin/libgnutls-extra-config
+bin/gnutls-serv
+bin/gnutls-cli
+bin/gnutls-srpcrypt
+bin/gnutls-cli-debug
+include/gnutls/extra.h
+include/gnutls/openssl.h
+include/gnutls/gnutls.h
+@dirrm include/gnutls
+lib/libgnutls.so.6
+lib/libgnutls.so
+lib/libgnutls.la
+lib/libgnutls.a
+lib/libgnutls-extra.so.6
+lib/libgnutls-extra.so
+lib/libgnutls-extra.la
+lib/libgnutls-extra.a
+share/aclocal/libgnutls.m4
+share/aclocal/libgnutls-extra.m4
+%%PORTDOCS%%share/doc/gnutls/AUTHORS
+%%PORTDOCS%%share/doc/gnutls/NEWS
+%%PORTDOCS%%share/doc/gnutls/README
+%%PORTDOCS%%share/doc/gnutls/THANKS
+%%PORTDOCS%%share/doc/gnutls/gnutls-logo.ps
+%%PORTDOCS%%share/doc/gnutls/gnutls.ps
+%%PORTDOCS%%@dirrm share/doc/gnutls
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
new file mode 100644
index 000000000000..b1e6a1a78d66
--- /dev/null
+++ b/security/gnutls/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gnutls
+# Date created: 13 Nov 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnutls
+PORTVERSION= 0.5.11
+CATEGORIES= security net
+MASTER_SITES= ftp://ftp.gnutls.org/pub/gnutls/ \
+ ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/ \
+ http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
+ ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/ \
+
+MAINTAINER= sergei@kolobov.com
+
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
+ tasn1:${PORTSDIR}/security/libtasn1
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+DOCS= AUTHORS NEWS README THANKS
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/tex/*.ps ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/gnutls/distinfo b/security/gnutls/distinfo
new file mode 100644
index 000000000000..35b3aaddb42c
--- /dev/null
+++ b/security/gnutls/distinfo
@@ -0,0 +1 @@
+MD5 (gnutls-0.5.11.tar.gz) = 9e86b8fb85be918a17c6734391de103f
diff --git a/security/gnutls/pkg-comment b/security/gnutls/pkg-comment
new file mode 100644
index 000000000000..2436d4683c53
--- /dev/null
+++ b/security/gnutls/pkg-comment
@@ -0,0 +1 @@
+GNU Transport Layer Security library
diff --git a/security/gnutls/pkg-descr b/security/gnutls/pkg-descr
new file mode 100644
index 000000000000..eb3b18b04920
--- /dev/null
+++ b/security/gnutls/pkg-descr
@@ -0,0 +1,17 @@
+GnuTLS is a portable ANSI C based library which implements the TLS 1.0 and
+SSL 3.0 protocols. The library does not include any patented algorithms and
+is available under the GNU Lesser GPL license.
+
+Important features of the GnuTLS library include:
+- Thread safety
+- Support for both TLS 1.0 and SSL 3.0 protocols
+- Support for both X.509 and OpenPGP certificates
+- Support for basic parsing and verification of certificates
+- Support for SRP for TLS authentication
+- Support for TLS Extension mechanism
+- Support for TLS Compression Methods
+
+Additionaly GnuTLS provides an emulation API for the widely used
+OpenSSL library, to ease integration with existing applications.
+
+WWW: http://www.gnutls.org/
diff --git a/security/gnutls/pkg-plist b/security/gnutls/pkg-plist
new file mode 100644
index 000000000000..8e7a4c6ab718
--- /dev/null
+++ b/security/gnutls/pkg-plist
@@ -0,0 +1,27 @@
+bin/libgnutls-config
+bin/libgnutls-extra-config
+bin/gnutls-serv
+bin/gnutls-cli
+bin/gnutls-srpcrypt
+bin/gnutls-cli-debug
+include/gnutls/extra.h
+include/gnutls/openssl.h
+include/gnutls/gnutls.h
+@dirrm include/gnutls
+lib/libgnutls.so.6
+lib/libgnutls.so
+lib/libgnutls.la
+lib/libgnutls.a
+lib/libgnutls-extra.so.6
+lib/libgnutls-extra.so
+lib/libgnutls-extra.la
+lib/libgnutls-extra.a
+share/aclocal/libgnutls.m4
+share/aclocal/libgnutls-extra.m4
+%%PORTDOCS%%share/doc/gnutls/AUTHORS
+%%PORTDOCS%%share/doc/gnutls/NEWS
+%%PORTDOCS%%share/doc/gnutls/README
+%%PORTDOCS%%share/doc/gnutls/THANKS
+%%PORTDOCS%%share/doc/gnutls/gnutls-logo.ps
+%%PORTDOCS%%share/doc/gnutls/gnutls.ps
+%%PORTDOCS%%@dirrm share/doc/gnutls