aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/p5-Crypt-CBC/Makefile29
-rw-r--r--security/p5-Crypt-CBC/distinfo1
-rw-r--r--security/p5-Crypt-CBC/pkg-comment1
-rw-r--r--security/p5-Crypt-CBC/pkg-descr5
-rw-r--r--security/p5-Crypt-CBC/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/security/p5-Crypt-CBC/Makefile b/security/p5-Crypt-CBC/Makefile
new file mode 100644
index 000000000000..f9a510f118c0
--- /dev/null
+++ b/security/p5-Crypt-CBC/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Crypt-DES
+# Version required: 1.20
+# Date created: October 20th 1996
+# Whom: Mark Murray <markm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= Crypt-CBC-1.20
+PKGNAME= p5-Crypt-CBC-1.20
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+
+MAINTAINER= markm@FreeBSD.org
+
+RUN_DEPENDS= ${PREFIX}/lib/perl5/site_perl/5.005/i386-freebsd/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+
+RESTRICTED= "Crypto; export-controlled"
+
+USE_PERL5= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::CBC.3
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-CBC/distinfo b/security/p5-Crypt-CBC/distinfo
new file mode 100644
index 000000000000..db4e7bde3a5d
--- /dev/null
+++ b/security/p5-Crypt-CBC/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-CBC-1.20.tar.gz) = 367aabe364846f46fdb052ce9e235f3e
diff --git a/security/p5-Crypt-CBC/pkg-comment b/security/p5-Crypt-CBC/pkg-comment
new file mode 100644
index 000000000000..523574951982
--- /dev/null
+++ b/security/p5-Crypt-CBC/pkg-comment
@@ -0,0 +1 @@
+Perl5 interface to Cipher Block Chaining with DES and IDEA
diff --git a/security/p5-Crypt-CBC/pkg-descr b/security/p5-Crypt-CBC/pkg-descr
new file mode 100644
index 000000000000..522865c17175
--- /dev/null
+++ b/security/p5-Crypt-CBC/pkg-descr
@@ -0,0 +1,5 @@
+This is Crypt::CBC, a Perl-only implementation of the cryptographic
+cipher block chaining mode (CBC). In combination with a block
+cipher such as Crypt::DES or Crypt::IDEA, you can encrypt and
+decrypt messages of arbitrarily long length. The encrypted messages
+are compatible with the encryption format used by B<SSLeay>.
diff --git a/security/p5-Crypt-CBC/pkg-plist b/security/p5-Crypt-CBC/pkg-plist
new file mode 100644
index 000000000000..24314186059e
--- /dev/null
+++ b/security/p5-Crypt-CBC/pkg-plist
@@ -0,0 +1,2 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/CBC.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt