aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/gnupg/Makefile2
-rw-r--r--security/gnupg/files/patch-g10__pkglue.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index b7040113dc0a..e5706a2ef746 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnupg
PORTVERSION= 2.0.17
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
diff --git a/security/gnupg/files/patch-g10__pkglue.c b/security/gnupg/files/patch-g10__pkglue.c
new file mode 100644
index 000000000000..cd1a8c3aed89
--- /dev/null
+++ b/security/gnupg/files/patch-g10__pkglue.c
@@ -0,0 +1,24 @@
+--- g10/pkglue.c.orig 2011-01-09 14:06:16.000000000 -0800
++++ g10/pkglue.c 2011-07-12 21:32:41.000000000 -0700
+@@ -34,10 +34,10 @@
+ {
+ gcry_sexp_t list;
+ gcry_mpi_t data;
+-
++
+ list = gcry_sexp_find_token (sexp, item, 0);
+ assert (list);
+- data = gcry_sexp_nth_mpi (list, 1, 0);
++ data = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
+ assert (data);
+ gcry_sexp_release (list);
+ return data;
+@@ -293,7 +293,7 @@
+ if (rc)
+ return rc;
+
+- *result = gcry_sexp_nth_mpi (s_plain, 0, 0);
++ *result = gcry_sexp_nth_mpi (s_plain, 0, GCRYMPI_FMT_USG);
+ gcry_sexp_release (s_plain);
+ if (!*result)
+ return -1; /* oops */