aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/ipsec-tools/Makefile4
-rw-r--r--security/libgcrypt/Makefile2
-rw-r--r--security/libident/Makefile4
-rw-r--r--security/libpwquality/Makefile3
-rw-r--r--security/libsecret/Makefile3
-rw-r--r--security/opencdk/Makefile6
-rw-r--r--security/p11-kit/Makefile3
-rw-r--r--security/pam-mysql/Makefile4
-rw-r--r--security/pkcs11-helper/Makefile6
9 files changed, 19 insertions, 16 deletions
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index e9220ef1cf3b..40acaead77f5 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ipsec-tools
PORTVERSION= 0.8.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= SF
@@ -23,7 +23,7 @@ USE_BZIP2= yes
INSTALL_TARGET= install-strip
-USES= libtool
+USES= libtool:keepla
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-shared --sysconfdir=${PREFIX}/etc/racoon \
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index c9ecd3155671..2da7936a8bc2 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgcrypt
PORTVERSION= 1.5.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/security/libident/Makefile b/security/libident/Makefile
index 09746f331688..29b16749e6c0 100644
--- a/security/libident/Makefile
+++ b/security/libident/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libident
PORTVERSION= 0.32
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://www.remlab.net/files/libident/
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Small library to interface the ident protocol server (rfc1413)
OPTIONS_DEFINE= DOCS
-USES= libtool
+USES= libtool:keepla
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/security/libpwquality/Makefile b/security/libpwquality/Makefile
index 7fb38e947962..022de165ffa6 100644
--- a/security/libpwquality/Makefile
+++ b/security/libpwquality/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libpwquality
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://fedorahosted.org/releases/l/i/libpwquality/
@@ -10,7 +11,7 @@ COMMENT= Library for generating random passwords and quality checking
LIB_DEPENDS= libcrack.so:${PORTSDIR}/security/cracklib
-USES= gettext gmake libtool pathfix
+USES= gettext gmake libtool:keepla pathfix
USE_BZIP2= yes
USE_GNOME= intltool
GNU_CONFIGURE= yes
diff --git a/security/libsecret/Makefile b/security/libsecret/Makefile
index 9f2767648327..1338a2e22267 100644
--- a/security/libsecret/Makefile
+++ b/security/libsecret/Makefile
@@ -4,6 +4,7 @@
PORTNAME= libsecret
PORTVERSION= 0.15
+PORTREVISION= 1
CATEGORIES= security gnome
MASTER_SITES= GNOME
@@ -15,7 +16,7 @@ LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
USE_XZ= yes
USE_GNOME= gnomehier glib20 libxslt:build intltool introspection:build
-USES= gettext gmake libtool pathfix pkgconfig
+USES= gettext gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-introspection --disable-vala
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index 79dd67ac102b..ee1b7ca4c23b 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opencdk
PORTVERSION= 0.6.6
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://josefsson.org/gnutls/releases/opencdk/
@@ -16,9 +16,9 @@ OPTIONS_DEFINE= DOCS
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= libtool pathfix pkgconfig
+USES= libtool:keepla pathfix pkgconfig
+USE_BZIP2= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
diff --git a/security/p11-kit/Makefile b/security/p11-kit/Makefile
index 198ef078af6f..71e10564f9c8 100644
--- a/security/p11-kit/Makefile
+++ b/security/p11-kit/Makefile
@@ -3,6 +3,7 @@
PORTNAME= p11-kit
PORTVERSION= 0.20.2
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://p11-glue.freedesktop.org/releases/
@@ -20,7 +21,7 @@ CONFIGURE_ARGS= --disable-nls --enable-debug=no \
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
MAKE_ENV= exampledir=${STAGEDIR}${EXAMPLESDIR}
-USES= gmake pkgconfig pathfix libtool
+USES= gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
pre-configure:
diff --git a/security/pam-mysql/Makefile b/security/pam-mysql/Makefile
index 8990b426c5a9..c8bf248458b8 100644
--- a/security/pam-mysql/Makefile
+++ b/security/pam-mysql/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pam_mysql
PORTVERSION= 0.7.r1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security databases
MASTER_SITES= SF/pam-mysql/pam-mysql/0.7RC1
DISTNAME= ${PORTNAME}-0.7RC1${DISTVERSIONSUFFIX}
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-0.7RC1${DISTVERSIONSUFFIX}
MAINTAINER= anders@FreeBSD.org
COMMENT= Pam module for authenticating with MySQL
-USES= libtool
+USES= libtool:keepla
USE_MYSQL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mysql=${LOCALBASE} --with-pam-mods-dir=${PREFIX}/lib --with-pam=/usr
diff --git a/security/pkcs11-helper/Makefile b/security/pkcs11-helper/Makefile
index 748d26ddab4c..ab3e7a1c79a4 100644
--- a/security/pkcs11-helper/Makefile
+++ b/security/pkcs11-helper/Makefile
@@ -3,12 +3,12 @@
PORTNAME= pkcs11-helper
PORTVERSION= 1.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security devel
MASTER_SITES= SF/opensc/pkcs11-helper/
MAINTAINER= ale@FreeBSD.org
-COMMENT= A helper library for multiple PKCS\#11 providers
+COMMENT= Helper library for multiple PKCS\#11 providers
LICENSE= BSD3CLAUSE GPLv2
LICENSE_COMB= dual
@@ -18,7 +18,7 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING.GPL
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USES= libtool pathfix pkgconfig tar:bzip2
+USES= libtool:keepla pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \