aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/openvas-client/Makefile24
-rw-r--r--security/openvas-client/distinfo3
-rw-r--r--security/openvas-client/files/patch-nessus-Makefile11
-rw-r--r--security/openvas-client/files/patch-nessus.tmpl.in11
-rw-r--r--security/openvas-client/files/patch-src-gui-Makefile11
-rw-r--r--security/openvas-client/pkg-descr6
-rw-r--r--security/openvas-client/pkg-plist3
8 files changed, 70 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6fff6d200e5c..8f853d43cdf7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -313,6 +313,7 @@
SUBDIR += openssl
SUBDIR += openssl-beta
SUBDIR += openssl-stable
+ SUBDIR += openvas-client
SUBDIR += openvpn
SUBDIR += openvpn-admin
SUBDIR += openvpn-auth-ldap
diff --git a/security/openvas-client/Makefile b/security/openvas-client/Makefile
new file mode 100644
index 000000000000..8a7517a2dece
--- /dev/null
+++ b/security/openvas-client/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: openvas-client
+# Date created: 2008-04-27
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openvas-client
+PORTVERSION= 1.0.3
+CATEGORIES= security
+MASTER_SITES= http://wald.intevation.org/frs/download.php/420/
+
+MAINTAINER= cherry@trombik.org
+COMMENT= A GUI client for OpenVAS
+
+MAN1= OpenVAS-Client.1 openvasclient-mkcert.1 openvasclient-mkrand.1
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
+
+.include <bsd.port.mk>
diff --git a/security/openvas-client/distinfo b/security/openvas-client/distinfo
new file mode 100644
index 000000000000..9c6843aee6e0
--- /dev/null
+++ b/security/openvas-client/distinfo
@@ -0,0 +1,3 @@
+MD5 (openvas-client-1.0.3.tar.gz) = bad1bc466055e1373053e9be47739206
+SHA256 (openvas-client-1.0.3.tar.gz) = b1affacb83c750e214bcc368babb66d2c49cea8dd375d75b33a959f6946e151a
+SIZE (openvas-client-1.0.3.tar.gz) = 694275
diff --git a/security/openvas-client/files/patch-nessus-Makefile b/security/openvas-client/files/patch-nessus-Makefile
new file mode 100644
index 000000000000..451d5541af03
--- /dev/null
+++ b/security/openvas-client/files/patch-nessus-Makefile
@@ -0,0 +1,11 @@
+--- nessus/Makefile.orig 2008-04-27 10:55:40.000000000 +0900
++++ nessus/Makefile 2008-04-27 10:56:19.000000000 +0900
+@@ -12,7 +12,7 @@
+ NESSUSCLIENT=OpenVAS-Client
+
+ # Add some specific Windows compile options for Cygwin
+-SYSTEM:=$(shell uname -o)
++SYSTEM:=$(shell uname -s)
+ ifeq ($(SYSTEM), Cygwin)
+ CFLAGS+=-mms-bitfields
+ LDFLAGS+=-mwindows
diff --git a/security/openvas-client/files/patch-nessus.tmpl.in b/security/openvas-client/files/patch-nessus.tmpl.in
new file mode 100644
index 000000000000..1f88bb388ebc
--- /dev/null
+++ b/security/openvas-client/files/patch-nessus.tmpl.in
@@ -0,0 +1,11 @@
+--- nessus.tmpl.in.orig 2008-04-27 11:39:30.000000000 +0900
++++ nessus.tmpl.in 2008-04-27 11:39:47.000000000 +0900
+@@ -37,7 +37,7 @@
+ make_bindir=${rootdir}/bin
+ libsdir=${rootdir}/libs
+ top_builddir = @PWDD@
+-include= -I. -I$(rootdir)/include
++include= -I. -I$(rootdir)/include -I$(includedir)
+ INSTALL=@INSTALL@
+ INSTALL_DIR=@INSTALL_DIR@
+ installuser=@installuser@
diff --git a/security/openvas-client/files/patch-src-gui-Makefile b/security/openvas-client/files/patch-src-gui-Makefile
new file mode 100644
index 000000000000..eedd6b297675
--- /dev/null
+++ b/security/openvas-client/files/patch-src-gui-Makefile
@@ -0,0 +1,11 @@
+--- src/gui/Makefile.orig 2008-04-27 10:56:55.000000000 +0900
++++ src/gui/Makefile 2008-04-27 10:57:17.000000000 +0900
+@@ -42,7 +42,7 @@
+ CFLAGS+=-Wall
+
+ # Add some specific Windows compile options for Cygwin
+-SYSTEM:=$(shell uname -o)
++SYSTEM:=$(shell uname -s)
+ ifeq ($(SYSTEM), Cygwin)
+ CFLAGS+=-mms-bitfields
+ LDFLAGS+=-mwindows
diff --git a/security/openvas-client/pkg-descr b/security/openvas-client/pkg-descr
new file mode 100644
index 000000000000..250f4bad0e3d
--- /dev/null
+++ b/security/openvas-client/pkg-descr
@@ -0,0 +1,6 @@
+OpenVAS stands for Open Vulnerability Assessment System and is a network
+security scanner with associated tools like a graphical user fontend. The core
+is a server component with a set of network vulnerability tests (NVTs) to
+detect security problems in remote systems and applications.
+
+WWW: http://www.openvas.org/
diff --git a/security/openvas-client/pkg-plist b/security/openvas-client/pkg-plist
new file mode 100644
index 000000000000..c29c42518e71
--- /dev/null
+++ b/security/openvas-client/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+bin/OpenVAS-Client
+bin/openvasclient-mkcert