aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/amavisd-new/Makefile2
-rw-r--r--security/archlinux-keyring/Makefile2
-rw-r--r--security/arti/Makefile2
-rw-r--r--security/authenticator/Makefile2
-rw-r--r--security/bzrtp/Makefile2
-rw-r--r--security/diffcode/Makefile2
-rw-r--r--security/lime/Makefile2
-rw-r--r--security/obfs4proxy-tor/Makefile2
-rw-r--r--security/olm/Makefile2
-rw-r--r--security/openvpn-devel/Makefile4
-rw-r--r--security/palisade/Makefile2
-rw-r--r--security/rotate/Makefile2
-rw-r--r--security/sequoia-sq/Makefile2
-rw-r--r--security/signing-party/Makefile2
-rw-r--r--security/webtunnel-tor/Makefile2
15 files changed, 16 insertions, 16 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index ebdfc1a3151e..a4487dfd74bf 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -24,7 +24,7 @@ USE_GITLAB= yes
USE_PERL5= run
GL_ACCOUNT= amavis
GL_PROJECT= amavis
-GL_COMMIT= 38f86957cfc161c23d12637ce206f5ae7ec3d0a8
+GL_TAGNAME= 38f86957cfc161c23d12637ce206f5ae7ec3d0a8
SHEBANG_FILES= amavisd-agent amavisd-nanny amavisd-release p0f-analyzer.pl \
amavisd-snmp-subagent amavisd
diff --git a/security/archlinux-keyring/Makefile b/security/archlinux-keyring/Makefile
index 061fa418ac7d..ff2a7a6c5f48 100644
--- a/security/archlinux-keyring/Makefile
+++ b/security/archlinux-keyring/Makefile
@@ -21,7 +21,7 @@ BINARY_ALIAS= install=ginstall
USE_GITLAB= yes
GL_SITE= https://gitlab.archlinux.org
GL_ACCOUNT= archlinux
-GL_COMMIT= f7749fd39c019922d504a43b7e94ceef6ae9e0ff
+GL_TAGNAME= f7749fd39c019922d504a43b7e94ceef6ae9e0ff
NO_ARCH= yes
diff --git a/security/arti/Makefile b/security/arti/Makefile
index 9b13e751e404..3ac4680b1353 100644
--- a/security/arti/Makefile
+++ b/security/arti/Makefile
@@ -19,7 +19,7 @@ PLIST_SUB= USERS="${USERS}" GROUPS="${GROUPS}"
USE_GITLAB= yes
GL_SITE= https://gitlab.torproject.org
GL_ACCOUNT= tpo/core
-GL_COMMIT= 6843093052d00f5fce00d2ae677379a811e36ab1
+GL_TAGNAME= 6843093052d00f5fce00d2ae677379a811e36ab1
CARGO_FEATURES= tokio rustls
CARGO_INSTALL= no
diff --git a/security/authenticator/Makefile b/security/authenticator/Makefile
index d371310401e3..1f029f697cd4 100644
--- a/security/authenticator/Makefile
+++ b/security/authenticator/Makefile
@@ -24,7 +24,7 @@ USE_GSTREAMER= gl zbar
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= World
GL_PROJECT= Authenticator
-GL_COMMIT= 77963b4714065939a86b329fe611d57d182a573e
+GL_TAGNAME= 77963b4714065939a86b329fe611d57d182a573e
CARGO_ENV= ZBAR_INCLUDE_DIRS="${LOCALBASE}/include" ZBAR_LIB_DIRS="${LOCALBASE}/lib"
MAKE_ENV= ${CARGO_ENV}
CARGO_BUILD= no
diff --git a/security/bzrtp/Makefile b/security/bzrtp/Makefile
index 8a3a7bf3ad40..cc564c76f7a0 100644
--- a/security/bzrtp/Makefile
+++ b/security/bzrtp/Makefile
@@ -16,7 +16,7 @@ CPE_VENDOR= ${PORTNAME}_project
USE_GITLAB= yes
GL_SITE= https://gitlab.linphone.org/BC
GL_ACCOUNT= public
-GL_COMMIT= bf66d442d1881eff4310ce9516e25f2616adfd35
+GL_TAGNAME= bf66d442d1881eff4310ce9516e25f2616adfd35
USE_GNOME= libxml2
USE_LDCONFIG= yes
diff --git a/security/diffcode/Makefile b/security/diffcode/Makefile
index ca446173ad61..7a15161ef0d4 100644
--- a/security/diffcode/Makefile
+++ b/security/diffcode/Makefile
@@ -14,6 +14,6 @@ USES= cmake
USE_GITLAB= yes
GL_ACCOUNT= LadySerenaKitty
GL_PROJECT= ${PORTNAME}
-GL_COMMIT= 4ae08b53b657ad2aa6816123b49709d903e4593c
+GL_TAGNAME= 4ae08b53b657ad2aa6816123b49709d903e4593c
.include <bsd.port.mk>
diff --git a/security/lime/Makefile b/security/lime/Makefile
index fc9fc2651f3c..5d95140c7fd7 100644
--- a/security/lime/Makefile
+++ b/security/lime/Makefile
@@ -17,7 +17,7 @@ USES= cmake
USE_GITLAB= yes
GL_SITE= https://gitlab.linphone.org/BC
GL_ACCOUNT= public
-GL_COMMIT= c20149550d1d9386cff67640d5391d0c814a7e70
+GL_TAGNAME= c20149550d1d9386cff67640d5391d0c814a7e70
CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
-DENABLE_STATIC=NO \
diff --git a/security/obfs4proxy-tor/Makefile b/security/obfs4proxy-tor/Makefile
index ca323c082d36..66e4119e8e82 100644
--- a/security/obfs4proxy-tor/Makefile
+++ b/security/obfs4proxy-tor/Makefile
@@ -29,7 +29,7 @@ GH_TUPLE= FiloSottile:edwards25519:v1.0.0:filosottile_edwards25519/vendor/filipp
USE_GITLAB= yes
GL_ACCOUNT= yawning
GL_PROJECT= obfs4
-GL_COMMIT= 336a71d6e4cfd2d33e9c57797828007ad74975e9
+GL_TAGNAME= 336a71d6e4cfd2d33e9c57797828007ad74975e9
GL_TUPLE= yawning:bsaes:0a714cd429ec754482b4001e918db30cd2094405:yawning_bsaes/vendor/gitlab.com/yawning/bsaes.git \
yawning:edwards25519-extra:def713fd18e464864613d2b55ef41a21df2c9493:yawning_edwards25519extra/vendor/gitlab.com/yawning/edwards25519-extra.git \
yawning:utls:f1bcf4b40e4596d0ccd1dbf8f3a9f4922f9759ca:yawning_utls/vendor/gitlab.com/yawning/utls.git
diff --git a/security/olm/Makefile b/security/olm/Makefile
index 08685d9b811a..1552702c9d44 100644
--- a/security/olm/Makefile
+++ b/security/olm/Makefile
@@ -14,7 +14,7 @@ CPE_VENDOR= matrix
USE_GITLAB= yes
GL_SITE= https://gitlab.matrix.org/
GL_ACCOUNT= matrix-org
-GL_COMMIT= 6d767aaf29bdf15571c2ef4d3f8f9e953de03733
+GL_TAGNAME= 6d767aaf29bdf15571c2ef4d3f8f9e953de03733
PLIST_SUB= SOVER=${DISTVERSION}
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index 0169fc98cccf..698b157e175b 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS+= liblzo2.so:archivers/lzo2
USES= autoreconf cpe libtool pkgconfig python:build shebangfix tar:xz
IGNORE_SSL= libressl libressl-devel
USE_GITLAB= yes
-GL_COMMIT= fafb05f6f3a7a1b46c278961ec8d2d8970f01096
+GL_TAGNAME= fafb05f6f3a7a1b46c278961ec8d2d8970f01096
USE_RC_SUBR= openvpn
SHEBANG_FILES= sample/sample-scripts/auth-pam.pl \
@@ -40,7 +40,7 @@ CONFIGURE_ENV+= PLUGINDIR="${PREFIX}/lib/openvpn/plugins"
CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
-CPPFLAGS+= -I${WRKSRC}/include -I${LOCALBASE}/include -DCONFIGURE_GIT_REVISION='\"${GL_COMMIT}\"' -DCONFIGURE_GIT_FLAGS=
+CPPFLAGS+= -I${WRKSRC}/include -I${LOCALBASE}/include -DCONFIGURE_GIT_REVISION='\"${GL_TAGNAME}\"' -DCONFIGURE_GIT_FLAGS=
LDFLAGS+= -L${LOCALBASE}/lib
CONFLICTS_INSTALL?= openvpn-2.[!4].* openvpn-[!2].* openvpn-beta \
diff --git a/security/palisade/Makefile b/security/palisade/Makefile
index bf72e4726979..8b0a9374bc17 100644
--- a/security/palisade/Makefile
+++ b/security/palisade/Makefile
@@ -18,7 +18,7 @@ USES= cmake:noninja,testing localbase # compiler:c++11-lang
USE_GITLAB= yes
USE_GITHUB= nodefault
GL_PROJECT= palisade-release # there's also palisade-development
-GL_COMMIT= 0860127401ab794591f931fa2c61426c7b56ee2d
+GL_TAGNAME= 0860127401ab794591f931fa2c61426c7b56ee2d
GH_TUPLE= \
JerryRyan:cereal:a384b101:cereal/third-party/cereal \
google:benchmark:e451e50e:benchmark/third-party/google-benchmark \
diff --git a/security/rotate/Makefile b/security/rotate/Makefile
index e522a753313a..50fc1c7e4ad1 100644
--- a/security/rotate/Makefile
+++ b/security/rotate/Makefile
@@ -14,6 +14,6 @@ USES= cmake
USE_GITLAB= yes
GL_ACCOUNT= LadySerenaKitty
GL_PROJECT= ${PORTNAME}
-GL_COMMIT= 11865e9748bb1a949c9450771283e4423b7c7115
+GL_TAGNAME= 11865e9748bb1a949c9450771283e4423b7c7115
.include <bsd.port.mk>
diff --git a/security/sequoia-sq/Makefile b/security/sequoia-sq/Makefile
index 0b27dbf852c9..2dc555d3a324 100644
--- a/security/sequoia-sq/Makefile
+++ b/security/sequoia-sq/Makefile
@@ -20,7 +20,7 @@ USES= cargo llvm sqlite ssl
USE_GITLAB= yes
GL_ACCOUNT= sequoia-pgp
GL_PROJECT= ${PKGNAMEPREFIX}${PORTNAME}
-GL_COMMIT= 3433e6e8064b45a6531c7b6b3374b6a2ed77d032
+GL_TAGNAME= 3433e6e8064b45a6531c7b6b3374b6a2ed77d032
OPTIONS_DEFINE= BASH FISH MANPAGES ZSH
OPTIONS_DEFAULT= BASH FISH MANPAGES ZSH
diff --git a/security/signing-party/Makefile b/security/signing-party/Makefile
index 16cf42e1d74c..3143fb6bcf46 100644
--- a/security/signing-party/Makefile
+++ b/security/signing-party/Makefile
@@ -29,7 +29,7 @@ CONFLICTS_INSTALL= pgpdir sig2dot springgraph # bin/gpgdir bin/sig2dot bin/sprin
USE_GITLAB= yes
GL_SITE= https://salsa.debian.org/
GL_ACCOUNT= signing-party-team
-GL_COMMIT= 8f6c9d59d8edbb08dade7bac06417fce07626f7f
+GL_TAGNAME= 8f6c9d59d8edbb08dade7bac06417fce07626f7f
BINS= keyanalyze/keyanalyze keyanalyze/process_keys \
gpgwrap/bin/gpgwrap
diff --git a/security/webtunnel-tor/Makefile b/security/webtunnel-tor/Makefile
index ff29b736553d..4f2eb738cc4c 100644
--- a/security/webtunnel-tor/Makefile
+++ b/security/webtunnel-tor/Makefile
@@ -26,7 +26,7 @@ GO_TARGET= ./main/client ./main/server
GL_SITE= https://gitlab.torproject.org/tpo
GL_ACCOUNT= anti-censorship/pluggable-transports
-GL_COMMIT= ${TPO_WEBTUN}
+GL_TAGNAME= ${TPO_WEBTUN}
GL_TUPLE= anti-censorship:pluggable-transports/goptlib:${TPO_GOPTLIB}:tpo_ac_ptlib/vendor/gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/goptlib
PLIST_FILES= bin/${PORTNAME}-tor-client \