aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion-classic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/bash-completion-classic/Makefile')
-rw-r--r--shells/bash-completion-classic/Makefile48
1 files changed, 0 insertions, 48 deletions
diff --git a/shells/bash-completion-classic/Makefile b/shells/bash-completion-classic/Makefile
deleted file mode 100644
index 4a1f38922bb4..000000000000
--- a/shells/bash-completion-classic/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-# New ports collection makefile for: bash_completion
-# Date created: 29 May 2003
-# Whom: kirk@strauser.com
-#
-# $FreeBSD$
-#
-
-PORTNAME= bash-completion
-PORTVERSION= 20050112
-CATEGORIES= shells
-MASTER_SITES= http://www.caliban.org/files/bash/
-
-MAINTAINER= kirk@strauser.com
-COMMENT= Programmable completion library for Bash 2.04 and up
-
-.if defined(WITH_BASH2)
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
-.else
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-.endif
-
-.if defined(WITH_GSED)
-RUN_DEPENDS+= gsed:${PORTSDIR}/textproc/gsed
-.endif
-
-WRKSRC= ${WRKDIR}/bash_completion
-NO_BUILD= yes
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PLIST_FILES= etc/bash_completion
-
-pre-everything::
- @${ECHO}
- @${ECHO} "You can build ${PKGNAME} with the following options:"
- @${ECHO} "WITH_BASH2 use shells/bash2 instead of shells/bash"
- @${ECHO} "WITH_GSED use GNU sed to enable additional completions"
- @${ECHO}
-
-pre-patch:
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}
-
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/bash_completion ${PREFIX}/etc/bash_completion
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>