aboutsummaryrefslogtreecommitdiff
path: root/shells/bash/files
diff options
context:
space:
mode:
Diffstat (limited to 'shells/bash/files')
-rw-r--r--shells/bash/files/patch-aa21
-rw-r--r--shells/bash/files/patch-ab11
-rw-r--r--shells/bash/files/patch-ac14
-rw-r--r--shells/bash/files/patch-ae151
-rw-r--r--shells/bash/files/patch-af14
-rw-r--r--shells/bash/files/patch-execute_cmd.c20
-rw-r--r--shells/bash/files/patch-terminal.c14
7 files changed, 0 insertions, 245 deletions
diff --git a/shells/bash/files/patch-aa b/shells/bash/files/patch-aa
deleted file mode 100644
index f30ca9d79b7b..000000000000
--- a/shells/bash/files/patch-aa
+++ /dev/null
@@ -1,21 +0,0 @@
-*** doc/Makefile.in.bak Fri Jan 31 00:12:33 1997
---- doc/Makefile.in Sat Jun 28 02:23:01 1997
-***************
-*** 155,161 ****
- -$(INSTALL_DATA) $(srcdir)/bashref.info $(infodir)/bash.info
- # run install-info if it is present to update the info directory
- if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
-! install-info --dir-file=$(infodir)/dir $(infodir)/bash.info; \
- else true; fi
-
- uninstall:
---- 155,163 ----
- -$(INSTALL_DATA) $(srcdir)/bashref.info $(infodir)/bash.info
- # run install-info if it is present to update the info directory
- if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
-! install-info \
-! --entry="* BASH: (bash). Bash Reference Manual." \
-! --dir-file=$(infodir)/dir $(infodir)/bash.info; \
- else true; fi
-
- uninstall:
diff --git a/shells/bash/files/patch-ab b/shells/bash/files/patch-ab
deleted file mode 100644
index db11179f5a31..000000000000
--- a/shells/bash/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Wed Mar 1 22:52:12 2000
-+++ Makefile.in Mon May 8 00:05:03 2000
-@@ -582,7 +582,7 @@
-
- install: .made installdirs
- $(INSTALL_PROGRAM) $(INSTALLMODE) $(Program) $(bindir)/$(Program)
-- $(INSTALL_PROGRAM) $(INSTALLMODE2) bashbug $(bindir)/bashbug
-+ $(INSTALL) $(INSTALLMODE2) bashbug $(bindir)/bashbug
- -( cd $(DOCDIR) ; $(MAKE) $(MFLAGS) \
- man1dir=$(man1dir) man1ext=$(man1ext) \
- man3dir=$(man3dir) man3ext=$(man3ext) \
diff --git a/shells/bash/files/patch-ac b/shells/bash/files/patch-ac
deleted file mode 100644
index 713ba4c2022e..000000000000
--- a/shells/bash/files/patch-ac
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig Tue Jan 23 19:57:28 2001
-+++ configure Tue Apr 10 12:17:23 2001
-@@ -763,7 +763,7 @@
- mips-irix6*) opt_bash_malloc=no ;; # needs 8-byte alignment
- m68k-sysv) opt_bash_malloc=no ;; # fixes file descriptor leak in closedir
- sparc-linux*) opt_bash_malloc=no ;; # sparc running linux; requires ELF
--#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
-+*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
- *-aix*) opt_bash_malloc=no ;; # AIX machines
- *-nextstep*) opt_bash_malloc=no ;; # NeXT machines running NeXTstep
- *-macos*) opt_bash_malloc=no ;; # Apple MacOS X
diff --git a/shells/bash/files/patch-ae b/shells/bash/files/patch-ae
deleted file mode 100644
index c0ae0bccf270..000000000000
--- a/shells/bash/files/patch-ae
+++ /dev/null
@@ -1,151 +0,0 @@
-diff -ru ../work/bash-2.04/builtins/shopt.def ./builtins/shopt.def
---- ../work/bash-2.04/builtins/shopt.def Tue Sep 21 17:20:01 1999
-+++ ./builtins/shopt.def Wed May 24 12:18:31 2000
-@@ -56,7 +56,7 @@
-
- #define OPTFMT "%-15s\t%s\n"
-
--extern int allow_null_glob_expansion, glob_dot_filenames;
-+extern int allow_null_glob_expansion, fail_glob_expansion, glob_dot_filenames;
- extern int cdable_vars, mail_warning, source_uses_path;
- extern int no_exit_on_failed_exec, print_shift_error;
- extern int check_hashed_filenames, promptvars, interactive_comments;
-@@ -137,6 +137,7 @@
- #endif
- { "nocaseglob", &glob_ignore_case, (Function *)NULL },
- { "nullglob", &allow_null_glob_expansion, (Function *)NULL },
-+ { "failglob", &fail_glob_expansion, (Function *)NULL },
- #if defined (PROGRAMMABLE_COMPLETION)
- { "progcomp", &prog_completion_enabled, (Function *)NULL },
- #endif
-diff -ru ../work/bash-2.04/doc/bash.1 ./doc/bash.1
---- ../work/bash-2.04/doc/bash.1 Tue Mar 14 17:37:56 2000
-+++ ./doc/bash.1 Wed May 24 12:17:39 2000
-@@ -2414,6 +2414,10 @@
- .B nullglob
- option is set, and no matches are found,
- the word is removed.
-+If the
-+.B failglob
-+option is set, and no matches are found, an error message is printed
-+and the command is not executed.
- If the shell option
- .B nocaseglob
- is enabled, the match is performed without regard to the case
-diff -ru ../work/bash-2.04/doc/bashref.texi ./doc/bashref.texi
---- ../work/bash-2.04/doc/bashref.texi Tue Mar 14 17:38:33 2000
-+++ ./doc/bashref.texi Wed May 24 12:17:39 2000
-@@ -1679,7 +1679,8 @@
- and replaced with an alphabetically sorted list of
- file names matching the pattern. If no matching file names are found,
- and the shell option @code{nullglob} is disabled, the word is left
--unchanged.
-+unchanged. If the @code{failglob} option is set, an error message is
-+printed and the commandline is not executed.
- If the @code{nullglob} option is set, and no matches are found, the word
- is removed.
- If the shell option @code{nocaseglob} is enabled, the match is performed
-@@ -1692,8 +1693,8 @@
- matched explicitly.
- In other cases, the @samp{.} character is not treated specially.
-
--See the description of @code{shopt} in @ref{Bash Builtins},
--for a description of the @code{nocaseglob}, @code{nullglob},
-+See the description of @code{shopt} in @ref{Bash Builtins}, for a
-+description of the @code{nocaseglob}, @code{nullglob}, @code{failglob}
- and @code{dotglob} options.
-
- The @code{GLOBIGNORE}
-@@ -3319,6 +3320,10 @@
- @item extglob
- If set, the extended pattern matching features described above
- (@pxref{Pattern Matching}) are enabled.
-+
-+@item failglob
-+If set, filenames that have globbing characters in them, but don't match
-+anything, will cause an error.
-
- @item histappend
- If set, the history list is appended to the file named by the value
-Only in ../work/bash-2.04/lib/readline/doc: Makefile
-diff -ru ../work/bash-2.04/subst.c ./subst.c
---- ../work/bash-2.04/subst.c Tue Mar 14 16:42:02 2000
-+++ ./subst.c Wed May 24 12:17:39 2000
-@@ -106,6 +106,9 @@
- a null file. */
- int allow_null_glob_expansion;
-
-+/* Non-zero means to signal an error when globbing fails to match. */
-+int fail_glob_expansion;
-+
- /* Variables to keep track of which words in an expanded word list (the
- output of expand_word_list_internal) are the result of globbing
- expansions. GLOB_ARGV_FLAGS is used by execute_cmd.c. */
-@@ -6018,6 +6021,11 @@
- {
- output_list = (WORD_LIST *)list_append (glob_list, output_list);
- PREPEND_LIST (tlist, disposables);
-+ }
-+ else if (fail_glob_expansion != 0)
-+ {
-+ report_error ("no match: %s", tlist->word->word);
-+ jump_to_top_level (DISCARD);
- }
- else if (allow_null_glob_expansion == 0)
- {
-diff -ru ../work/bash-2.04/tests/shopt.right ./tests/shopt.right
---- ../work/bash-2.04/tests/shopt.right Tue Sep 21 17:55:58 1999
-+++ ./tests/shopt.right Wed May 24 12:17:23 2000
-@@ -21,6 +21,7 @@
- shopt -u no_empty_cmd_completion
- shopt -u nocaseglob
- shopt -u nullglob
-+shopt -u failglob
- shopt -s progcomp
- shopt -s promptvars
- shopt -u restricted_shell
-@@ -56,6 +57,7 @@
- shopt -u no_empty_cmd_completion
- shopt -u nocaseglob
- shopt -u nullglob
-+shopt -u failglob
- shopt -u restricted_shell
- shopt -u shift_verbose
- shopt -u xpg_echo
-@@ -75,6 +77,7 @@
- no_empty_cmd_completion off
- nocaseglob off
- nullglob off
-+failglob off
- restricted_shell off
- shift_verbose off
- xpg_echo off
-@@ -198,3 +201,5 @@
- --
- ./shopt.tests: shopt: xyz1: unknown shell option name
- ./shopt.tests: shopt: xyz1: unknown option name
-+tmp/l1 tmp/l2 tmp/*4 tmp/l3
-+./shopt.tests: no match: tmp/*4
-diff -ru ../work/bash-2.04/tests/shopt.tests ./tests/shopt.tests
---- ../work/bash-2.04/tests/shopt.tests Tue Sep 21 17:49:32 1999
-+++ ./tests/shopt.tests Wed May 24 12:17:39 2000
-@@ -21,6 +21,7 @@
- shopt -u mailwarn
- shopt -u nocaseglob
- shopt -u nullglob
-+shopt -u failglob
- shopt -s promptvars
- shopt -u shift_verbose
- shopt -s sourcepath
-@@ -92,3 +93,11 @@
- builtin printf -- "--\n"
- shopt -p xyz1
- shopt -o -p xyz1
-+
-+mkdir tmp
-+touch tmp/l1 tmp/l2 tmp/l3
-+builtin echo tmp/l[12] tmp/*4 tmp/*3
-+shopt -s failglob
-+builtin echo tmp/l[12] tmp/*4 tmp/*3
-+rm -r tmp
-+shopt -u failglob
diff --git a/shells/bash/files/patch-af b/shells/bash/files/patch-af
deleted file mode 100644
index 73c7e7972ed3..000000000000
--- a/shells/bash/files/patch-af
+++ /dev/null
@@ -1,14 +0,0 @@
---- error.c.old Wed May 24 12:04:50 2000
-+++ error.c Wed May 24 12:05:21 2000
-@@ -465,9 +465,9 @@
- terminal. */
- void
- #if defined (PREFER_STDARG)
--trace (const char *format, ...)
-+bash_trace (const char *format, ...)
- #else
--trace (format, va_alist)
-+bash_trace (format, va_alist)
- const char *format;
- va_dcl
- #endif
diff --git a/shells/bash/files/patch-execute_cmd.c b/shells/bash/files/patch-execute_cmd.c
deleted file mode 100644
index e50bfb5bd1e0..000000000000
--- a/shells/bash/files/patch-execute_cmd.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- execute_cmd.c.shellfunc Tue Jan 25 11:29:11 2000
-+++ execute_cmd.c Tue May 2 21:26:24 2000
-@@ -2762,6 +2762,8 @@
- if (tc && (flags & CMD_IGNORE_RETURN))
- tc->flags |= CMD_IGNORE_RETURN;
-
-+ old_shell_function = this_shell_function;
-+
- if (subshell == 0)
- {
- begin_unwind_frame ("function_calling");
-@@ -2843,6 +2845,8 @@
-
- if (variable_context == 0 || this_shell_function == 0)
- make_funcname_visible (0);
-+
-+ this_shell_function = old_shell_function;
-
- return (result);
- }
diff --git a/shells/bash/files/patch-terminal.c b/shells/bash/files/patch-terminal.c
deleted file mode 100644
index 73e5c793650b..000000000000
--- a/shells/bash/files/patch-terminal.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- lib/readline/terminal.c.orig Tue Feb 6 12:39:22 2001
-+++ lib/readline/terminal.c Wed Apr 11 09:43:44 2001
-@@ -297,7 +297,11 @@
- { "im", &_rl_term_im },
- { "kd", &_rl_term_kd },
- { "kh", &_rl_term_kh }, /* home */
-+#ifdef __FreeBSD__
-+ { "@7", &_rl_term_kH }, /* end */
-+#else
- { "kH", &_rl_term_kH }, /* end */
-+#endif
- { "kl", &_rl_term_kl },
- { "kr", &_rl_term_kr },
- { "ku", &_rl_term_ku },