aboutsummaryrefslogtreecommitdiff
path: root/shells/bash1
diff options
context:
space:
mode:
Diffstat (limited to 'shells/bash1')
-rw-r--r--shells/bash1/Makefile14
-rw-r--r--shells/bash1/distinfo1
-rw-r--r--shells/bash1/files/patch-ab56
-rw-r--r--shells/bash1/files/patch-ac40
-rw-r--r--shells/bash1/files/patch-ad21
-rw-r--r--shells/bash1/pkg-comment1
-rw-r--r--shells/bash1/pkg-descr8
-rw-r--r--shells/bash1/pkg-plist8
8 files changed, 0 insertions, 149 deletions
diff --git a/shells/bash1/Makefile b/shells/bash1/Makefile
deleted file mode 100644
index 81561adc0ba5..000000000000
--- a/shells/bash1/Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-# New ports collection makefile for: bash
-# Version required: 1.14.4
-# Date created: 21 August 1994
-# Whom: jkh
-#
-# $Id: Makefile,v 1.9 1995/04/11 19:26:27 asami Exp $
-#
-
-DISTNAME= bash-1.14.4
-CATEGORIES+= shells
-MASTER_SITES= ftp://slc2.ins.cwru.edu/pub/dist/
-MAINTAINER= ache@FreeBSD.ORG
-
-.include <bsd.port.mk>
diff --git a/shells/bash1/distinfo b/shells/bash1/distinfo
deleted file mode 100644
index 88a7cadab252..000000000000
--- a/shells/bash1/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (bash-1.14.4.tar.gz) = bc1f600f6884984314d1439ed1450801
diff --git a/shells/bash1/files/patch-ab b/shells/bash1/files/patch-ab
deleted file mode 100644
index d41ffcfd88cd..000000000000
--- a/shells/bash1/files/patch-ab
+++ /dev/null
@@ -1,56 +0,0 @@
-*** cpp-Makefile.orig Tue Jan 31 00:48:36 1995
---- cpp-Makefile Fri Mar 17 03:24:29 1995
-***************
-*** 138,144 ****
---- 138,148 ----
- /usr/include. Then it will break.) */
- CC = gcc -traditional -I/usr/include $(GCC_EXTRAS)
- # else /* HAVE_FIXED_INCLUDES */
-+ #ifdef __FreeBSD__
-+ CC += $(GCC_EXTRAS)
-+ #else
- CC = gcc $(GCC_EXTRAS)
-+ #endif
- # endif /* HAVE_FIXED_INCLUDES */
- #else /* !HAVE_GCC */
- CC = CPP_CC
-***************
-*** 155,162 ****
---- 159,171 ----
- RM = rm -f
- AR = ar
-
-+ #ifndef __FreeBSD__
- INSTALL_PROGRAM = install -c
- INSTALL_DATA = install -c -m 644
-+ #else
-+ INSTALL_PROGRAM = install -c -o bin -g bin -m 555
-+ INSTALL_DATA = install -c -o bin -g bin -m 644
-+ #endif
-
- COMPRESS = gzip
- COMPRESS_EXT = .gz
-***************
-*** 304,310 ****
---- 313,321 ----
- /**/# The GNU coding standards don't recognize the possibility that
- /**/# other information besides optimization and debugging might be
- /**/# passed to cc. A different name should have been used.
-+ #ifndef __FreeBSD__
- CFLAGS = -O -g
-+ #endif
-
- SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
- $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
-***************
-*** 312,317 ****
---- 323,331 ----
- $(VARARGSH) $(STRCHR) $(STRCASE) $(DEVFD) \
- -D$(Machine) -D$(OS)
- LDFLAGS = $(NOSHARE) $(SYSDEP_LD) $(EXTRA_LD_PATH) $(PROFILE_FLAGS) $(CFLAGS)
-+ #ifdef __FreeBSD__
-+ LDFLAGS += -s
-+ #endif
- CCFLAGS = $(PROFILE_FLAGS) $(SYSTEM_FLAGS) -DSHELL $(ALLOCA_CFLAGS) \
- $(MALLOC_CFLAGS) $(CFLAGS)
- CPPFLAGS= -I. -I$(srcdir) -I$(LIBSRC)
diff --git a/shells/bash1/files/patch-ac b/shells/bash1/files/patch-ac
deleted file mode 100644
index 8c2733eacc55..000000000000
--- a/shells/bash1/files/patch-ac
+++ /dev/null
@@ -1,40 +0,0 @@
-*** readline.c.bak Tue Dec 6 01:47:48 1994
---- lib/readline/readline.c Mon Dec 12 04:29:49 1994
-***************
-*** 958,964 ****
- static void
- readline_initialize_everything ()
- {
-! char *t;
-
- /* Find out if we are running in Emacs. */
- running_in_emacs = getenv ("EMACS") != (char *)0;
---- 958,964 ----
- static void
- readline_initialize_everything ()
- {
-! char *t, *t1;
-
- /* Find out if we are running in Emacs. */
- running_in_emacs = getenv ("EMACS") != (char *)0;
-***************
-*** 993,999 ****
- /* Check for LC_CTYPE and use its value to decide the defaults for
- 8-bit character input and output. */
- t = getenv ("LC_CTYPE");
-! if (t && (strcmp (t, "iso-8859-1") == 0 || strcmp (t, "iso_8859_1") == 0))
- {
- _rl_meta_flag = 1;
- _rl_convert_meta_chars_to_ascii = 0;
---- 993,1003 ----
- /* Check for LC_CTYPE and use its value to decide the defaults for
- 8-bit character input and output. */
- t = getenv ("LC_CTYPE");
-! t1 = getenv ("LANG");
-! if (t && (strstr (t, "8859-1") != NULL || strstr (t, "8859_1") != NULL ||
-! strstr (t, "KOI8-R") != NULL || strstr (t, "koi8-r") != NULL) ||
-! t1 && (strstr (t1, "8859-1") != NULL || strstr (t1, "8859_1") != NULL ||
-! strstr (t1, "KOI8-R") != NULL || strstr (t1, "koi8-r") != NULL))
- {
- _rl_meta_flag = 1;
- _rl_convert_meta_chars_to_ascii = 0;
diff --git a/shells/bash1/files/patch-ad b/shells/bash1/files/patch-ad
deleted file mode 100644
index 8f66ce9ed935..000000000000
--- a/shells/bash1/files/patch-ad
+++ /dev/null
@@ -1,21 +0,0 @@
-*** documentation/Makefile.bak Fri Jan 6 23:48:35 1995
---- documentation/Makefile Fri Jan 6 23:50:06 1995
-***************
-*** 109,116 ****
- -[ -d $(mandir) ] || mkdir $(mandir)
- $(INSTALL_DATA) bash.1 $(mandir)
- sed 's:so bash.1:so man1/bash.1:' < builtins.1 > $(mandir)/bash_builtins.1
-! -[ -d $(man3dir) ] || mkdir $(man3dir)
-! $(INSTALL_DATA) readline.3 $(man3dir)
- -[ -d $(infodir) ] || mkdir $(infodir)
- $(INSTALL_DATA) features.info $(infodir)/bash.info
-
---- 109,116 ----
- -[ -d $(mandir) ] || mkdir $(mandir)
- $(INSTALL_DATA) bash.1 $(mandir)
- sed 's:so bash.1:so man1/bash.1:' < builtins.1 > $(mandir)/bash_builtins.1
-! # -[ -d $(man3dir) ] || mkdir $(man3dir)
-! # $(INSTALL_DATA) readline.3 $(man3dir)
- -[ -d $(infodir) ] || mkdir $(infodir)
- $(INSTALL_DATA) features.info $(infodir)/bash.info
-
diff --git a/shells/bash1/pkg-comment b/shells/bash1/pkg-comment
deleted file mode 100644
index 2470326d00fa..000000000000
--- a/shells/bash1/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-bash, the GNU Borne Again Shell. Version 1.14.4
diff --git a/shells/bash1/pkg-descr b/shells/bash1/pkg-descr
deleted file mode 100644
index 497fcff47de1..000000000000
--- a/shells/bash1/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-Bash is the GNU Project's Bourne
-Again SHell, an interactive shell with Bourne shell syntax (/bin/sh);
-but also with interactive command line editing, job control on
-architectures that support it, Csh-like history features and brace
-expansion, and a slew of other stuff. For more information on the
-features of Bash that are new to this type of shell, see the file
-`documentation/features.texi'. There is also a processed DVI file
-there, as well as a large man page.
diff --git a/shells/bash1/pkg-plist b/shells/bash1/pkg-plist
deleted file mode 100644
index 8d51f4a46878..000000000000
--- a/shells/bash1/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-@cwd /usr/local
-bin/bash
-@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
-@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
-bin/bashbug
-man/man1/bash.1
-man/man1/bash_builtins.1
-info/bash.info