aboutsummaryrefslogtreecommitdiff
path: root/shells/bash
diff options
context:
space:
mode:
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile41
-rw-r--r--shells/bash/distinfo2
-rw-r--r--shells/bash/files/patch-aa21
-rw-r--r--shells/bash/files/patch-ab11
-rw-r--r--shells/bash/files/patch-ac20
-rw-r--r--shells/bash/files/patch-ad11
-rw-r--r--shells/bash/files/patch-ae151
-rw-r--r--shells/bash/files/patch-af14
-rw-r--r--shells/bash/pkg-comment1
-rw-r--r--shells/bash/pkg-descr10
-rw-r--r--shells/bash/pkg-plist11
11 files changed, 0 insertions, 293 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
deleted file mode 100644
index a9a8ba9fe9f4..000000000000
--- a/shells/bash/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# New ports collection makefile for: bash
-# Date created: 21 August 1994
-# Whom: jkh
-#
-# $FreeBSD$
-#
-
-PORTNAME= bash
-PORTVERSION= 2.04
-CATEGORIES= shells
-MASTER_SITES= ${MASTER_SITE_GNU} \
- ftp://ftp.cwru.edu/pub/bash/
-MASTER_SITE_SUBDIR= bash
-.if !defined(NOPORTDOCS)
-DISTFILES= bash-${PORTVERSION}.tar.gz bash-doc-${PORTVERSION}.tar.gz
-.endif
-
-MAINTAINER= ache@FreeBSD.org
-
-GNU_CONFIGURE= Yes
-CONFIGURE_ARGS= --with-installed-readline
-CONFIGURE_ENV= LDFLAGS=-static
-MAN1= bash.1 bashbug.1
-
-post-install:
- ${CP} /etc/shells /etc/shells.bak
- (${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; ${ECHO} ${PREFIX}/bin/bash) >/etc/shells
- ${RM} /etc/shells.bak
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/bash
- ${INSTALL_MAN} \
- ${WRKDIR}/doc/article.ps \
- ${WRKDIR}/doc/bashref.ps \
- ${PREFIX}/share/doc/bash
- ${INSTALL_MAN} \
- ${WRKDIR}/doc/article.txt \
- ${PREFIX}/share/doc/bash
- ${GZIP_CMD} ${PREFIX}/share/doc/bash/*.ps
-.endif
-
-.include <bsd.port.mk>
diff --git a/shells/bash/distinfo b/shells/bash/distinfo
deleted file mode 100644
index fdeba66bf41c..000000000000
--- a/shells/bash/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (bash-2.04.tar.gz) = 49b548a8b72a4c925ff26930e4c31c6c
-MD5 (bash-doc-2.04.tar.gz) = a9684d1095e7ea1adb8759c3f4fca13d
diff --git a/shells/bash/files/patch-aa b/shells/bash/files/patch-aa
deleted file mode 100644
index f30ca9d79b7b..000000000000
--- a/shells/bash/files/patch-aa
+++ /dev/null
@@ -1,21 +0,0 @@
-*** doc/Makefile.in.bak Fri Jan 31 00:12:33 1997
---- doc/Makefile.in Sat Jun 28 02:23:01 1997
-***************
-*** 155,161 ****
- -$(INSTALL_DATA) $(srcdir)/bashref.info $(infodir)/bash.info
- # run install-info if it is present to update the info directory
- if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
-! install-info --dir-file=$(infodir)/dir $(infodir)/bash.info; \
- else true; fi
-
- uninstall:
---- 155,163 ----
- -$(INSTALL_DATA) $(srcdir)/bashref.info $(infodir)/bash.info
- # run install-info if it is present to update the info directory
- if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
-! install-info \
-! --entry="* BASH: (bash). Bash Reference Manual." \
-! --dir-file=$(infodir)/dir $(infodir)/bash.info; \
- else true; fi
-
- uninstall:
diff --git a/shells/bash/files/patch-ab b/shells/bash/files/patch-ab
deleted file mode 100644
index db11179f5a31..000000000000
--- a/shells/bash/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Wed Mar 1 22:52:12 2000
-+++ Makefile.in Mon May 8 00:05:03 2000
-@@ -582,7 +582,7 @@
-
- install: .made installdirs
- $(INSTALL_PROGRAM) $(INSTALLMODE) $(Program) $(bindir)/$(Program)
-- $(INSTALL_PROGRAM) $(INSTALLMODE2) bashbug $(bindir)/bashbug
-+ $(INSTALL) $(INSTALLMODE2) bashbug $(bindir)/bashbug
- -( cd $(DOCDIR) ; $(MAKE) $(MFLAGS) \
- man1dir=$(man1dir) man1ext=$(man1ext) \
- man3dir=$(man3dir) man3ext=$(man3ext) \
diff --git a/shells/bash/files/patch-ac b/shells/bash/files/patch-ac
deleted file mode 100644
index 33c30ce82e7e..000000000000
--- a/shells/bash/files/patch-ac
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig Tue Feb 22 19:46:17 2000
-+++ configure Mon May 8 00:23:05 2000
-@@ -761,7 +761,7 @@
- mips-irix6*) opt_bash_malloc=no ;; # needs 8-byte alignment
- m68k-sysv) opt_bash_malloc=no ;; # fixes file descriptor leak in closedir
- sparc-linux*) opt_bash_malloc=no ;; # sparc running linux; requires ELF
--#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
-+*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
- *-aix*) opt_bash_malloc=no ;; # AIX machines
- *-nextstep*) opt_bash_malloc=no ;; # NeXT machines running NeXTstep
- *-rhapsody*) opt_bash_malloc=no ;; # Apple Rhapsody
-@@ -8099,7 +8099,7 @@
- then
- echo $ac_n "checking shared object configuration for loadable builtins""... $ac_c" 1>&6
- echo "configure:8102: checking shared object configuration for loadable builtins" >&5
-- eval `${CONFIG_SHELL-/bin/sh} ${srcdir}/support/shobj-conf -C "${CC}" -c ${host_cpu} -o ${host_os} -v ${host_vendor}`
-+ eval `${CONFIG_SHELL-/bin/sh} ${srcdir}/support/shobj-conf -C "${CC}" -c "${host_cpu}" -o "${host_os}" -v "${host_vendor}"`
-
-
-
diff --git a/shells/bash/files/patch-ad b/shells/bash/files/patch-ad
deleted file mode 100644
index db321acb895b..000000000000
--- a/shells/bash/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- support/shobj-conf.orig Tue Sep 21 21:03:43 1999
-+++ support/shobj-conf Mon May 8 00:12:30 2000
-@@ -97,7 +97,7 @@
- # ;;
-
- # FreeBSD-3.x ELF
--freebsd3*)
-+freebsd[3-9]*)
- SHOBJ_CFLAGS=-fpic
- SHOBJ_LD='${CC}'
-
diff --git a/shells/bash/files/patch-ae b/shells/bash/files/patch-ae
deleted file mode 100644
index c0ae0bccf270..000000000000
--- a/shells/bash/files/patch-ae
+++ /dev/null
@@ -1,151 +0,0 @@
-diff -ru ../work/bash-2.04/builtins/shopt.def ./builtins/shopt.def
---- ../work/bash-2.04/builtins/shopt.def Tue Sep 21 17:20:01 1999
-+++ ./builtins/shopt.def Wed May 24 12:18:31 2000
-@@ -56,7 +56,7 @@
-
- #define OPTFMT "%-15s\t%s\n"
-
--extern int allow_null_glob_expansion, glob_dot_filenames;
-+extern int allow_null_glob_expansion, fail_glob_expansion, glob_dot_filenames;
- extern int cdable_vars, mail_warning, source_uses_path;
- extern int no_exit_on_failed_exec, print_shift_error;
- extern int check_hashed_filenames, promptvars, interactive_comments;
-@@ -137,6 +137,7 @@
- #endif
- { "nocaseglob", &glob_ignore_case, (Function *)NULL },
- { "nullglob", &allow_null_glob_expansion, (Function *)NULL },
-+ { "failglob", &fail_glob_expansion, (Function *)NULL },
- #if defined (PROGRAMMABLE_COMPLETION)
- { "progcomp", &prog_completion_enabled, (Function *)NULL },
- #endif
-diff -ru ../work/bash-2.04/doc/bash.1 ./doc/bash.1
---- ../work/bash-2.04/doc/bash.1 Tue Mar 14 17:37:56 2000
-+++ ./doc/bash.1 Wed May 24 12:17:39 2000
-@@ -2414,6 +2414,10 @@
- .B nullglob
- option is set, and no matches are found,
- the word is removed.
-+If the
-+.B failglob
-+option is set, and no matches are found, an error message is printed
-+and the command is not executed.
- If the shell option
- .B nocaseglob
- is enabled, the match is performed without regard to the case
-diff -ru ../work/bash-2.04/doc/bashref.texi ./doc/bashref.texi
---- ../work/bash-2.04/doc/bashref.texi Tue Mar 14 17:38:33 2000
-+++ ./doc/bashref.texi Wed May 24 12:17:39 2000
-@@ -1679,7 +1679,8 @@
- and replaced with an alphabetically sorted list of
- file names matching the pattern. If no matching file names are found,
- and the shell option @code{nullglob} is disabled, the word is left
--unchanged.
-+unchanged. If the @code{failglob} option is set, an error message is
-+printed and the commandline is not executed.
- If the @code{nullglob} option is set, and no matches are found, the word
- is removed.
- If the shell option @code{nocaseglob} is enabled, the match is performed
-@@ -1692,8 +1693,8 @@
- matched explicitly.
- In other cases, the @samp{.} character is not treated specially.
-
--See the description of @code{shopt} in @ref{Bash Builtins},
--for a description of the @code{nocaseglob}, @code{nullglob},
-+See the description of @code{shopt} in @ref{Bash Builtins}, for a
-+description of the @code{nocaseglob}, @code{nullglob}, @code{failglob}
- and @code{dotglob} options.
-
- The @code{GLOBIGNORE}
-@@ -3319,6 +3320,10 @@
- @item extglob
- If set, the extended pattern matching features described above
- (@pxref{Pattern Matching}) are enabled.
-+
-+@item failglob
-+If set, filenames that have globbing characters in them, but don't match
-+anything, will cause an error.
-
- @item histappend
- If set, the history list is appended to the file named by the value
-Only in ../work/bash-2.04/lib/readline/doc: Makefile
-diff -ru ../work/bash-2.04/subst.c ./subst.c
---- ../work/bash-2.04/subst.c Tue Mar 14 16:42:02 2000
-+++ ./subst.c Wed May 24 12:17:39 2000
-@@ -106,6 +106,9 @@
- a null file. */
- int allow_null_glob_expansion;
-
-+/* Non-zero means to signal an error when globbing fails to match. */
-+int fail_glob_expansion;
-+
- /* Variables to keep track of which words in an expanded word list (the
- output of expand_word_list_internal) are the result of globbing
- expansions. GLOB_ARGV_FLAGS is used by execute_cmd.c. */
-@@ -6018,6 +6021,11 @@
- {
- output_list = (WORD_LIST *)list_append (glob_list, output_list);
- PREPEND_LIST (tlist, disposables);
-+ }
-+ else if (fail_glob_expansion != 0)
-+ {
-+ report_error ("no match: %s", tlist->word->word);
-+ jump_to_top_level (DISCARD);
- }
- else if (allow_null_glob_expansion == 0)
- {
-diff -ru ../work/bash-2.04/tests/shopt.right ./tests/shopt.right
---- ../work/bash-2.04/tests/shopt.right Tue Sep 21 17:55:58 1999
-+++ ./tests/shopt.right Wed May 24 12:17:23 2000
-@@ -21,6 +21,7 @@
- shopt -u no_empty_cmd_completion
- shopt -u nocaseglob
- shopt -u nullglob
-+shopt -u failglob
- shopt -s progcomp
- shopt -s promptvars
- shopt -u restricted_shell
-@@ -56,6 +57,7 @@
- shopt -u no_empty_cmd_completion
- shopt -u nocaseglob
- shopt -u nullglob
-+shopt -u failglob
- shopt -u restricted_shell
- shopt -u shift_verbose
- shopt -u xpg_echo
-@@ -75,6 +77,7 @@
- no_empty_cmd_completion off
- nocaseglob off
- nullglob off
-+failglob off
- restricted_shell off
- shift_verbose off
- xpg_echo off
-@@ -198,3 +201,5 @@
- --
- ./shopt.tests: shopt: xyz1: unknown shell option name
- ./shopt.tests: shopt: xyz1: unknown option name
-+tmp/l1 tmp/l2 tmp/*4 tmp/l3
-+./shopt.tests: no match: tmp/*4
-diff -ru ../work/bash-2.04/tests/shopt.tests ./tests/shopt.tests
---- ../work/bash-2.04/tests/shopt.tests Tue Sep 21 17:49:32 1999
-+++ ./tests/shopt.tests Wed May 24 12:17:39 2000
-@@ -21,6 +21,7 @@
- shopt -u mailwarn
- shopt -u nocaseglob
- shopt -u nullglob
-+shopt -u failglob
- shopt -s promptvars
- shopt -u shift_verbose
- shopt -s sourcepath
-@@ -92,3 +93,11 @@
- builtin printf -- "--\n"
- shopt -p xyz1
- shopt -o -p xyz1
-+
-+mkdir tmp
-+touch tmp/l1 tmp/l2 tmp/l3
-+builtin echo tmp/l[12] tmp/*4 tmp/*3
-+shopt -s failglob
-+builtin echo tmp/l[12] tmp/*4 tmp/*3
-+rm -r tmp
-+shopt -u failglob
diff --git a/shells/bash/files/patch-af b/shells/bash/files/patch-af
deleted file mode 100644
index 73c7e7972ed3..000000000000
--- a/shells/bash/files/patch-af
+++ /dev/null
@@ -1,14 +0,0 @@
---- error.c.old Wed May 24 12:04:50 2000
-+++ error.c Wed May 24 12:05:21 2000
-@@ -465,9 +465,9 @@
- terminal. */
- void
- #if defined (PREFER_STDARG)
--trace (const char *format, ...)
-+bash_trace (const char *format, ...)
- #else
--trace (format, va_alist)
-+bash_trace (format, va_alist)
- const char *format;
- va_dcl
- #endif
diff --git a/shells/bash/pkg-comment b/shells/bash/pkg-comment
deleted file mode 100644
index 2049031d771d..000000000000
--- a/shells/bash/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-The GNU Borne Again Shell
diff --git a/shells/bash/pkg-descr b/shells/bash/pkg-descr
deleted file mode 100644
index b3a252cb863f..000000000000
--- a/shells/bash/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-Bash is the GNU Project's Bourne
-Again SHell, an interactive shell with Bourne shell syntax (/bin/sh);
-but also with interactive command line editing, job control on
-architectures that support it, Csh-like history features and brace
-expansion, and a slew of other stuff. For more information on the
-features of Bash that are new to this type of shell, see the file
-`documentation/features.texi'. There is also a processed DVI file
-there, as well as a large man page.
-
-WWW: http://www.gnu.org/software/bash/
diff --git a/shells/bash/pkg-plist b/shells/bash/pkg-plist
deleted file mode 100644
index b08793be186e..000000000000
--- a/shells/bash/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-bin/bash
-@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
-@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
-bin/bashbug
-@unexec install-info --delete %D/info/bash.info %D/info/dir
-info/bash.info
-@exec install-info %D/info/bash.info %D/info/dir
-share/doc/bash/article.ps.gz
-share/doc/bash/bashref.ps.gz
-share/doc/bash/article.txt
-@dirrm share/doc/bash