aboutsummaryrefslogtreecommitdiff
path: root/shells/bush/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/bush/Makefile')
-rw-r--r--shells/bush/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/shells/bush/Makefile b/shells/bush/Makefile
index 1f600e3743b2..4a922df164e2 100644
--- a/shells/bush/Makefile
+++ b/shells/bush/Makefile
@@ -22,9 +22,11 @@ BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat \
USE_PGSQL= yes
HAS_CONFIGURE= yes
+ADACFLAGS?= ${CFLAGS:N-fno-strict-aliasing}
USE_GMAKE= yes
MAKE_ARGS= GMAKE=${GMAKE} CPUTYPE=${CPUTYPE} PTHREAD_LIBS=${PTHREAD_LIBS} \
SDL_CONFIG=${SDL_CONFIG}
+MAKE_ENV= ADACFLAGS="${ADACFLAGS}"
MAKEFILE= GNUmakefile
USE_SDL= sdl image
USE_MYSQL= yes