aboutsummaryrefslogtreecommitdiff
path: root/shells/dash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/dash/Makefile')
-rw-r--r--shells/dash/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/shells/dash/Makefile b/shells/dash/Makefile
index f650134f037e..52e8fc9a626b 100644
--- a/shells/dash/Makefile
+++ b/shells/dash/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= dash
-PORTVERSION= 0.5.9.1
+PORTVERSION= 0.5.10.2
CATEGORIES= shells
MASTER_SITES= http://gondor.apana.org.au/~herbert/dash/files/
@@ -12,12 +12,14 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-# This work in 11-CURRENT r266677M amd64 but fails to work in 11.0-CURRENT r266677 i386
+# SIGRTMAX is larger than NSIG*2 which mksignames.c does not support. Just
+# disable RT signal handling.
CFLAGS+= -DUNUSABLE_RT_SIGNALS
USES= gmake
-PLIST_FILES= bin/dash man/man1/dash.1.gz
+PLIST_FILES= bin/dash \
+ man/man1/dash.1.gz
post-patch:
${REINPLACE_CMD} -e '/COMMON_CFLAGS =/ s|$$| ${CFLAGS}|' \