aboutsummaryrefslogtreecommitdiff
path: root/shells/gscommander/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/gscommander/Makefile')
-rw-r--r--shells/gscommander/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/shells/gscommander/Makefile b/shells/gscommander/Makefile
new file mode 100644
index 000000000000..40636450bc90
--- /dev/null
+++ b/shells/gscommander/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: gscommander
+# Date created: 15 Mar 2003
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gscommander
+PORTVERSION= 0.1
+CATEGORIES= shells
+MASTER_SITES= http://www.nice.ch/~phip/
+DISTNAME= GSCommander-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= GNUstep simple unix command monitor
+
+BUILD_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
+RUN_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
+
+PREFIX= ${LOCALBASE}/GNUstep
+WRKSRC= ${WRKDIR}/GSCommander
+GUN_CONFIGURE= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET=
+NO_MTREE= yes
+
+BACKBUNDLEDIR= ${PREFIX}/System/Library/Bundles/libgnustep-back.bundle/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
+
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "i386"
+GNU_ARCH= ix86
+.else
+GNU_ARCH= ${MACHINE_ARCH}
+.endif
+
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
+
+do-build:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+
+do-install:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+
+.include <bsd.port.post.mk>