aboutsummaryrefslogtreecommitdiff
path: root/shells/perlsh
diff options
context:
space:
mode:
Diffstat (limited to 'shells/perlsh')
-rw-r--r--shells/perlsh/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/shells/perlsh/Makefile b/shells/perlsh/Makefile
index 69513addf12c..46691f1f1abe 100644
--- a/shells/perlsh/Makefile
+++ b/shells/perlsh/Makefile
@@ -1,19 +1,18 @@
# New ports collection makefile for: perlsh
-# Version required: 0.007
# Date created: 11 Dec 1999
# Whom: Will Andrews <andrews@technologist.com>
#
# $FreeBSD$
#
-DISTNAME= psh-${VERSION}
-PKGNAME= perlsh-${VERSION}
+PORTNAME= perlsh
+PORTVERSION= 0.007
CATEGORIES= shells perl5
MASTER_SITES= http://www.focusresearch.com/gregor/psh/
+DISTNAME= psh-${PORTVERSION}
MAINTAINER= will@FreeBSD.org
-VERSION= 0.007
USE_PERL5= yes
FETCH_BEFORE_ARGS+= -t
MAKE_ENV+= PPREFIX="${PREFIX}"
@@ -25,8 +24,8 @@ MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-build:
@(cd ${WRKSRC} && ${PERL} Makefile.PL && ${MAKE})
-post-install:
- @${ECHO} "Updating /etc/shells"
+post-install:
+ @${ECHO} "Updating /etc/shells"
@${CP} /etc/shells /etc/shells.bak
@(${GREP} -v ${PREFIX}/bin/psh /etc/shells.bak; \
${ECHO} ${PREFIX}/bin/psh) > /etc/shells