aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/zsh/Makefile')
-rw-r--r--shells/zsh/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 6b6ae0cd2cdd..7172e8c95c7f 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -73,6 +73,11 @@ SHELLS= /etc/shells
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 602107
+# also needed for early versions of 7.0-CURRENT, but we don't care
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ncurses
+.endif
+
.if defined(WITH_ZSH_PCRE)
CONFIGURE_ARGS+= --enable-pcre
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
@@ -104,7 +109,7 @@ CONFIGURE_ARGS+= --enable-multibyte
.endif
.if ${OSVERSION} >= 503000
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-bsdtar
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsdtar
.endif
post-patch: