aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
Diffstat (limited to 'shells')
-rw-r--r--shells/lshell/Makefile2
-rw-r--r--shells/lshell/files/patch-lshell_shellcmd.py11
2 files changed, 12 insertions, 1 deletions
diff --git a/shells/lshell/Makefile b/shells/lshell/Makefile
index b62e000092b2..179b3a5494f1 100644
--- a/shells/lshell/Makefile
+++ b/shells/lshell/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lshell
PORTVERSION= 0.9.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= SF
diff --git a/shells/lshell/files/patch-lshell_shellcmd.py b/shells/lshell/files/patch-lshell_shellcmd.py
new file mode 100644
index 000000000000..4512cc2c8629
--- /dev/null
+++ b/shells/lshell/files/patch-lshell_shellcmd.py
@@ -0,0 +1,11 @@
+--- lshell/shellcmd.py.orig 2013-09-07 23:07:08 UTC
++++ lshell/shellcmd.py
+@@ -134,7 +134,7 @@ class ShellCmd(cmd.Cmd, object):
+ self.g_arg = ' '.join(self.g_line.split()[1:])
+ self.cd()
+ else:
+- os.system('set -m; %s' % self.g_line)
++ os.system('%s' % self.g_line)
+ elif self.g_cmd not in ['', '?', 'help', None]:
+ self.log.warn('INFO: unknown syntax -> "%s"' %self.g_line)
+ self.stderr.write('*** unknown syntax: %s\n' %self.g_cmd)