aboutsummaryrefslogtreecommitdiff
path: root/sysutils/amrstat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/amrstat/Makefile')
-rw-r--r--sysutils/amrstat/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/sysutils/amrstat/Makefile b/sysutils/amrstat/Makefile
index c1792bef1c71..114b98699478 100644
--- a/sysutils/amrstat/Makefile
+++ b/sysutils/amrstat/Makefile
@@ -14,14 +14,15 @@ MASTER_SITE_SUBDIR= jkim
MAINTAINER= jkim@FreeBSD.org
COMMENT= Utility for LSI Logic's MegaRAID RAID controllers
-OPTIONS= MEGARC "Also install LSI megarc binary port.." off
+OPTIONS_DEFINE= MEGARC
+MEGARC_DESC= "Install LSI megarc binary port"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# We may want this for periodic script and to actually be able
# to fix something in case amrstat reports degraded RAID.
-.if defined(WITH_MEGARC)
-RUN_DEPENDS= ${LOCALBASE}/sbin/megarc:${PORTSDIR}/sysutils/megarc
+.if ${PORT_OPTIONS:MMEGARC}
+RUN_DEPENDS+= ${LOCALBASE}/sbin/megarc:${PORTSDIR}/sysutils/megarc
.endif
ALL_TARGET= ${PORTNAME}
@@ -41,4 +42,4 @@ do-install:
${INSTALL_SCRIPT} -d ${PREFIX}/etc/periodic/daily
${INSTALL_SCRIPT} ${WRKDIR}/${PERIODICSCRIPT} ${PREFIX}/etc/periodic/daily
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>