aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bareos17-client-static/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/bareos17-client-static/Makefile')
-rw-r--r--sysutils/bareos17-client-static/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/bareos17-client-static/Makefile b/sysutils/bareos17-client-static/Makefile
new file mode 100644
index 000000000000..b6855572b9c5
--- /dev/null
+++ b/sysutils/bareos17-client-static/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= bareos17
+PKGNAMESUFFIX= -client-static
+
+COMMENT= Backup archiving recovery open sourced (static client)
+
+CONFLICTS= bareos16-client-static-*
+
+PLIST= ${.CURDIR}/pkg-plist
+MASTERDIR= ${.CURDIR}/../../sysutils/bareos17-server
+
+PLIST_FILES= sbin/bareos-fd-static \
+ sbin/bconsole-static
+
+OPTIONS_DEFINE= NLS LMDB
+LMDB_DESC= Enable build of LMDB support
+
+CONFIGURE_ARGS+= --enable-client-only \
+ --enable-static-fd \
+ --enable-static-cons \
+ --disable-libtool \
+ --disable-build-dird \
+ --disable-build-stored \
+ --with-jansson=${LOCALBASE}
+
+BROKEN_aarch64= Fails to link: missing sbrk
+
+.include "${MASTERDIR}/Makefile"