aboutsummaryrefslogtreecommitdiff
path: root/sysutils/brasero/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/brasero/Makefile')
-rw-r--r--sysutils/brasero/Makefile28
1 files changed, 22 insertions, 6 deletions
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
index d915447a33ca..1121385058d9 100644
--- a/sysutils/brasero/Makefile
+++ b/sysutils/brasero/Makefile
@@ -3,11 +3,11 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/brasero/Makefile,v 1.34 2009/01/09 22:03:01 kwm Exp $
+# $MCom: ports/sysutils/brasero/Makefile,v 1.43 2009/03/22 00:17:29 marcus Exp $
PORTNAME= brasero
-PORTVERSION= 0.8.4
-PORTREVISION= 3
+PORTVERSION= 2.26.0
+PORTREVISION= 1
CATEGORIES= sysutils audio multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,20 +17,36 @@ COMMENT= CD/DVD mastering tool for the GNOME desktop
LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
totem-plparser.12:${PORTSDIR}/multimedia/totem-pl-parser
+RUN_DEPENDS= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
+ cdrdao:${PORTSDIR}/sysutils/cdrdao
USE_GETTEXT= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehier nautiluscdburner
+USE_XORG= sm
+USE_GNOME= intlhack gnomeprefix gnomehack nautilus2
USE_GSTREAMER= gconf core
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --disable-inotify
+CONFIGURE_ARGS= --disable-inotify --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_CAM_LIB_H=1" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= brasero.1
GCONF_SCHEMAS= brasero.schemas
-.include <bsd.port.mk>
+OPTIONS= LIBBURNIA "Enable libburnia plug-ins" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LIBBURNIA)
+LIB_DEPENDS+= burn.4:${PORTSDIR}/devel/libburn \
+ isofs.6:${PORTSDIR}/devel/libisofs
+CONFIGURE_ARGS+=--enable-libburnia
+PLIST_SUB+= LIBBURNIA=""
+.else
+PLIST_SUB+= LIBBURNIA="@comment "
+.endif
+
+.include <bsd.port.post.mk>