aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine-masterfiles38/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/cfengine-masterfiles38/Makefile')
-rw-r--r--sysutils/cfengine-masterfiles38/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/cfengine-masterfiles38/Makefile b/sysutils/cfengine-masterfiles38/Makefile
new file mode 100644
index 000000000000..003dff6c217a
--- /dev/null
+++ b/sysutils/cfengine-masterfiles38/Makefile
@@ -0,0 +1,34 @@
+# Created by: cy@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= cfengine-masterfiles
+PORTVERSION= 3.8.0
+CATEGORIES= sysutils
+MASTER_SITES= https://cfengine-package-repos.s3.amazonaws.com/tarballs/
+
+MAINTAINER= cy@FreeBSD.org
+# gjb@FreeBSD.org is also committer for this port
+# skreuzer@FreeBSD.org is also committer for this port
+COMMENT= cfengine sample policies for installations and upgrades
+
+LICENSE= GPLv3
+
+CPE_VENDOR= gnu
+
+.if !defined(MASTERDIR)
+PKGNAMESUFFIX= 38
+.endif
+
+RUN_DEPENDS= cf-agent:${PORTSDIR}/sysutils/cfengine${PKGNAMESUFFIX}
+
+FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
+
+CONFLICTS= cfengine-masterfiles[234]*
+
+MAKE_JOBS_UNSAFE= yes
+USES= cpe
+HAS_CONFIGURE= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/cfengine-masterfiles
+CONFIGURE_ARGS= --prefix=${EXAMPLESDIR}
+
+.include <bsd.port.mk>