aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cronolog
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/cronolog')
-rw-r--r--sysutils/cronolog/Makefile19
-rw-r--r--sysutils/cronolog/distinfo3
-rw-r--r--sysutils/cronolog/pkg-descr21
3 files changed, 26 insertions, 17 deletions
diff --git a/sysutils/cronolog/Makefile b/sysutils/cronolog/Makefile
index c092e3a2cad9..889a2f094494 100644
--- a/sysutils/cronolog/Makefile
+++ b/sysutils/cronolog/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cronolog
PORTVERSION= 1.6.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://cronolog.org/download/
@@ -18,4 +19,20 @@ MAN1= cronolog.1m cronosplit.1m
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+OPTIONS= SETUID_PATCH "Build with setuid functionality" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_SETUID_PATCH)
+MASTER_SITES+= http://cronolog.org/patches/:patches
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} cronolog-setugid-patch.txt:patches
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+EXTRA_PATCHES= ${WRKDIR}/cronolog-setugid-patch.txt
+PATCH_WRKSRC= ${WRKDIR}
+USE_DOS2UNIX= ../cronolog-setugid-patch.txt
+.endif
+
+post-extract:
+ ${CP} ${DISTDIR}/cronolog-setugid-patch.txt ${WRKDIR}/
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cronolog/distinfo b/sysutils/cronolog/distinfo
index 245eac86548a..3bcbedebe8c4 100644
--- a/sysutils/cronolog/distinfo
+++ b/sysutils/cronolog/distinfo
@@ -1,3 +1,6 @@
MD5 (cronolog-1.6.2.tar.gz) = a44564fd5a5b061a5691b9a837d04979
SHA256 (cronolog-1.6.2.tar.gz) = 65e91607643e5aa5b336f17636fa474eb6669acc89288e72feb2f54a27edb88e
SIZE (cronolog-1.6.2.tar.gz) = 133591
+MD5 (cronolog-setugid-patch.txt) = 5aa5d56b2ad762fa2e2509e2e785810e
+SHA256 (cronolog-setugid-patch.txt) = ca0061a34aa1291ac61cac07d7718bc2a09421fb931943fa45f33cf7d5a0759b
+SIZE (cronolog-setugid-patch.txt) = 13321
diff --git a/sysutils/cronolog/pkg-descr b/sysutils/cronolog/pkg-descr
index 270675ad361f..6d50a9847886 100644
--- a/sysutils/cronolog/pkg-descr
+++ b/sysutils/cronolog/pkg-descr
@@ -1,12 +1,9 @@
"cronolog" is a simple program that reads log messages from its input
and writes them to a set of output files, the names of which are
-constructed using template and the current date and time. The
-template uses the same format specifiers as the Unix date command
-(which are the same as the standard C strftime library function).
+constructed using template and the current date and time.
"cronolog" is intended to be used in conjunction with a Web server, such
-as Apache to split the access log into daily or monthly logs. For
-example the Apache configuration directives:
+as Apache to split the access log into daily or monthly logs. E.g.:
TransferLog "|/www/sbin/cronolog /www/logs/%Y/%m/%d/access.log"
ErrorLog "|/www/sbin/cronolog /www/logs/%Y/%m/%d/errors.log"
@@ -14,22 +11,14 @@ example the Apache configuration directives:
would instruct Apache to pipe its access and error log messages into
separate copies of cronolog, which would create new log files each day
in a directory hierarchy structured by date, i.e. on 31 December 1996
-messages would be written to
+messages would be written to:
/www/logs/1996/12/31/access.log
/www/logs/1996/12/31/errors.log
-after midnight the files
+After midnight the following files would be used:
/www/logs/1997/01/01/access.log
/www/logs/1997/01/01/errors.log
-would be used, with the directories 1997, 1997/01 and 1997/01/01 being
-created if they did not already exist.
-
-The most up-to-date version of "cronolog" can be found at:
-
- WWW: http://cronolog.org/
-
-- Mark Blackman
-tmb@maddog.u-net.com
+WWW: http://cronolog.org/