aboutsummaryrefslogtreecommitdiff
path: root/sysutils/duplicity/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/duplicity/files/patch-setup.py')
-rw-r--r--sysutils/duplicity/files/patch-setup.py88
1 files changed, 83 insertions, 5 deletions
diff --git a/sysutils/duplicity/files/patch-setup.py b/sysutils/duplicity/files/patch-setup.py
index 3a86163122d2..cdcf2ce84ce9 100644
--- a/sysutils/duplicity/files/patch-setup.py
+++ b/sysutils/duplicity/files/patch-setup.py
@@ -1,6 +1,14 @@
---- setup.py.orig 2011-11-25 23:58:57.147597966 +0000
-+++ setup.py 2011-11-26 00:00:43.169721395 +0000
-@@ -31,6 +31,10 @@
+--- setup.py.orig 2014-05-18 14:37:42.190089675 +0100
++++ setup.py 2014-05-18 14:41:15.084751008 +0100
+@@ -22,7 +22,6 @@
+
+ import sys, os
+ from setuptools import setup, Extension
+-from setuptools.command.test import test
+ from setuptools.command.install import install
+ from setuptools.command.sdist import sdist
+
+@@ -34,6 +33,10 @@
incdir_list = libdir_list = None
@@ -11,7 +19,7 @@
if os.name == 'posix':
LIBRSYNC_DIR = os.environ.get('LIBRSYNC_DIR', '')
args = sys.argv[:]
-@@ -42,17 +46,9 @@
+@@ -45,17 +48,9 @@
incdir_list = [os.path.join(LIBRSYNC_DIR, 'include')]
libdir_list = [os.path.join(LIBRSYNC_DIR, 'lib')]
@@ -29,4 +37,74 @@
- 'CHANGELOG']),
]
- assert os.path.exists("po"), "Missing 'po' directory."
+ top_dir = os.path.dirname(os.path.abspath(__file__))
+@@ -70,45 +65,8 @@
+ ["po/%s/duplicity.mo" % lang]))
+
+
+-class TestCommand(test):
+- def run(self):
+- # Make sure all modules are ready
+- build_cmd = self.get_finalized_command("build_py")
+- build_cmd.run()
+- # And make sure our scripts are ready
+- build_scripts_cmd = self.get_finalized_command("build_scripts")
+- build_scripts_cmd.run()
+-
+- # make symlinks for test data
+- if build_cmd.build_lib != top_dir:
+- for path in ['testfiles.tar.gz', 'testtar.tar', 'gnupg']:
+- src = os.path.join(top_dir, 'testing', path)
+- target = os.path.join(build_cmd.build_lib, 'testing', path)
+- try:
+- os.symlink(src, target)
+- except Exception:
+- pass
+-
+- os.environ['PATH'] = "%s:%s" % (
+- os.path.abspath(build_scripts_cmd.build_dir),
+- os.environ.get('PATH'))
+-
+- test.run(self)
+-
+-
+ class InstallCommand(install):
+ def run(self):
+- # Normally, install will call build(). But we want to delete the
+- # testing dir between building and installing. So we manually build
+- # and mark ourselves to skip building when we run() for real.
+- self.run_command('build')
+- self.skip_build = True
+-
+- # This should always be true, but just to make sure!
+- if self.build_lib != top_dir:
+- testing_dir = os.path.join(self.build_lib, 'testing')
+- os.system("rm -rf %s" % testing_dir)
+-
+ install.run(self)
+
+
+@@ -133,11 +91,7 @@
+ maintainer_email="kenneth@loafman.com",
+ url="http://duplicity.nongnu.org/index.html",
+ packages = ['duplicity',
+- 'duplicity.backends',
+- 'testing',
+- 'testing.functional',
+- 'testing.overrides',
+- 'testing.unit'],
++ 'duplicity.backends'],
+ package_dir = {"duplicity" : "duplicity",
+ "duplicity.backends" : "duplicity/backends",},
+ ext_modules = [Extension("duplicity._librsync",
+@@ -147,9 +101,6 @@
+ libraries=["rsync"])],
+ scripts = ['bin/rdiffdir', 'bin/duplicity'],
+ data_files = data_files,
+- tests_require = ['lockfile', 'mock'],
+- test_suite = 'testing',
+- cmdclass={'test': TestCommand,
+- 'install': InstallCommand,
++ cmdclass={'install': InstallCommand,
+ 'sdist': SDistCommand},
+ )