aboutsummaryrefslogtreecommitdiff
path: root/sysutils/empower/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/empower/Makefile')
-rw-r--r--sysutils/empower/Makefile28
1 files changed, 18 insertions, 10 deletions
diff --git a/sysutils/empower/Makefile b/sysutils/empower/Makefile
index c07191916eaa..606e0f69a329 100644
--- a/sysutils/empower/Makefile
+++ b/sysutils/empower/Makefile
@@ -7,22 +7,30 @@
#
PORTNAME= empower
-PORTVERSION= 20080223
-PORTREVISION= 5
-CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
+PORTVERSION= 20101003
+CATEGORIES= sysutils enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/extra/
MAINTAINER= stas@FreeBSD.org
COMMENT= A graphical sudo tool based on the EFL
+RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo
+
+DIST_SUBDIR= e17
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig gnometarget
-USE_EFL= evas ecore edje ewl etk
-WANT_EFL= yes
GNU_CONFIGURE= yes
+USE_EFL= evas ecore edje elementary
+USE_EFL_ECORE= file imf evas
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_GMAKE= yes
+USE_LDCONFIG= yes
-PLIST_FILES= bin/empower \
- bin/empower-askpass
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
.include <bsd.port.mk>