aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fcron/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/fcron/Makefile')
-rw-r--r--sysutils/fcron/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/sysutils/fcron/Makefile b/sysutils/fcron/Makefile
index 5a9dd6aee8ae..d96cff2a39de 100644
--- a/sysutils/fcron/Makefile
+++ b/sysutils/fcron/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME= fcron
-PORTVERSION= 3.0.0
-PORTREVISION= 2
+PORTVERSION= 3.0.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- http://fcron.free.fr/
+ http://fcron.free.fr/archives/ \
+ ftp://ftp.seul.org/pub/fcron/
MASTER_SITE_SUBDIR= system/daemons/cron
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -23,7 +23,7 @@ USE_GMAKE= yes
USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
--with-rootname=root --with-rootgroup=wheel \
- --with-docdir=${DOCSDIR} --with-fcrondyn=no
+ --with-docdir=${DOCSDIR}
WRKSRC= ${WRKDIR}/fcron-${PORTVERSION}
@@ -36,12 +36,19 @@ MAN8= fcron.8
PORTDOCS= *
+.if defined(MANLANG) && exists(${WRKSRC}/doc/${MANLANG})
+DOCSRC= ${WRKSRC}/doc/${MANLANG}
+.else
+DOCSRC= ${WRKSRC}/doc/en
+.endif
+
pre-su-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fcron ${PREFIX}/sbin
${INSTALL_PROGRAM} -g fcron -o fcron -m 6111 ${WRKSRC}/fcrontab ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -g fcron -o fcron -m 6111 ${WRKSRC}/fcrondyn ${PREFIX}/bin
${INSTALL_PROGRAM} -g fcron -m 4110 ${WRKSRC}/fcronsighup ${PREFIX}/bin
.for f in fcron.allow fcron.conf fcron.deny
${INSTALL_DATA} -g fcron -m 640 ${WRKSRC}/files/${f} ${PREFIX}/etc/${f}.dist
@@ -49,12 +56,12 @@ do-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/fcrontab-* ${WRKSRC}/files/*.pam ${EXAMPLESDIR}
.for n in 1 5 8
- ${INSTALL_MAN} ${MAN${n}:S|^|${WRKSRC}/doc/man/|} ${PREFIX}/man/man${n}
+ ${INSTALL_MAN} ${MAN${n}:S|^|${DOCSRC}/man/|} ${PREFIX}/man/man${n}
.endfor
.if !defined(NOPORTDOCS)
. for d in txt HTML
${MKDIR} ${DOCSDIR}/${d}
- ${INSTALL_DATA} ${WRKSRC}/doc/${d}/* ${DOCSDIR}/${d}
+ ${INSTALL_DATA} ${DOCSRC}/${d}/* ${DOCSDIR}/${d}
. endfor
.endif