aboutsummaryrefslogtreecommitdiff
path: root/sysutils/flock
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/flock')
-rw-r--r--sysutils/flock/Makefile1
-rw-r--r--sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp18
2 files changed, 19 insertions, 0 deletions
diff --git a/sysutils/flock/Makefile b/sysutils/flock/Makefile
index 93d03cf2e782..d5c1dff568ef 100644
--- a/sysutils/flock/Makefile
+++ b/sysutils/flock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flock
PORTVERSION= 3.4
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/ \
http://archive.progeny.com/pundits/
diff --git a/sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp b/sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void