aboutsummaryrefslogtreecommitdiff
path: root/sysutils/froxlor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/froxlor/Makefile')
-rw-r--r--sysutils/froxlor/Makefile97
1 files changed, 67 insertions, 30 deletions
diff --git a/sysutils/froxlor/Makefile b/sysutils/froxlor/Makefile
index 13f624c5ea8e..770e9517f507 100644
--- a/sysutils/froxlor/Makefile
+++ b/sysutils/froxlor/Makefile
@@ -1,83 +1,120 @@
-# New ports collection makefile for: froxlor
-# Date created: 2010-10-13
-# Whom: Marco Steinbach <coco@executive-computing.de>
-#
+# Created by: Marco Steinbach <coco@executive-computing.de>
# $FreeBSD$
-#
PORTNAME= froxlor
-DISTVERSION= 0.9.26
+DISTVERSION= 0.9.27
CATEGORIES= sysutils www
MASTER_SITES= http://files.froxlor.org/releases/
MAINTAINER= coco@executive-computing.de
COMMENT= PHP-based ISP Server Management Panel
+LICENSE= GPLv2
+
WRKSRC= ${WRKDIR}
NO_BUILD= YES
SUB_FILES+= pkg-message pkg-deinstall
-USE_PHP= xml bcmath posix filter session ftp mysqli gettext
+USE_PHP= xml bcmath posix filter session ftp mysql mysqli gettext
USE_GETTEXT= RUN
-OPTIONS= APACHE "Use Apache (2.2) as http server" On \
- MYSQL "Use MySQL as database server" On \
- POSTFIX "Use Postfix as smtp server" On \
- DKIM "Use OpenDKIM" Off \
- DOVECOT "Use Dovecot as imap/pop3 server" On \
- PROFTPD "Use Proftpd-mysql as ftp server (implies MySQL)" On \
- POWERDNS "Use Powerdns as dns server" Off \
- LIBNSS "Use Libnss-mysql for authentication (impl. MySQL)" Off \
- WEBALIZER "Use webalizer" On \
- AWSTATS "Use awstats" Off \
- LOGROTATE "Use logrotate" Off
+OPTIONS_DEFINE= POWERDNS LIBNSS LOGROTATE MYSQLS DKIM
+
+OPTIONS_SINGLE= WEB SMTP IMAPPOP3 FTP
+OPTIONS_SINGLE_WEB= APACHE LIGHTTPD NGINX
+OPTIONS_SINGLE_SMTP= POSTFIX EXIM
+OPTIONS_SINGLE_IMAPPOP3= DOVECOT COURIER
+OPTIONS_SINGLE_FTP= PROFTPD PUREFTPD
+OPTIONS_MULTI= WWWST
+OPTIONS_MULTI_WWWST= WEBALIZER AWSTATS
+
+APACHE_DESC= Apache (2.2) as HTTP server
+LIGHTTPD_DESC= Lighttpd as HTTP server
+NGINX_DESC= Nginx as HTTP server
+MYSQLC_DESC= MySQL database client only
+MYSQLS_DESC= MySQL database server and client
+POSTFIX_DESC= Postfix as SMTP server
+EXIM_DESC= Exim as SMTP server
+DKIM_DESC= OpenDKIM for DomainKeys Identified Mail
+DOVECOT_DESC= Dovecot as IMAP/POP3 server
+COURIER_DESC= Courier as IMAP/POP3 server
+PROFTPD_DESC= ProFTPd as FTP server
+PUREFTPD_DESC= Pure-FTPd as FTP server
+POWERDNS_DESC= Powerdns as DNS server
+LIBNSS_DESC= Libnss-mysql for authentication
+WEBALIZER_DESC= Webalizer for web statistics
+AWSTATS_DESC= Awstats for web statistics
+LOGROTATE_DESC= Logrotate for log rotation
+MYSQLS_DESC= Install/depend on MySQL server
+
+OPTIONS_DEFAULT= APACHE MYSQLS POSTFIX DOVECOT PROFTPD WEBALIZER MYSQLS
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE_RUN= 22
.endif
-.if !defined(WITHOUT_MYSQL)
-USE_PHP+= mysql
+.if ${PORT_OPTIONS:MLIGHTTPD}
+RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
+.endif
+
+.if ${PORT_OPTIONS:MNGINX}
+RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
.endif
-.if !defined(WITHOUT_POSTFIX)
+.if ${PORT_OPTIONS:MMYSQLS}
+USE_MYSQL= server
+.endif
+
+.if ${PORT_OPTIONS:MPOSTFIX}
RUN_DEPENDS+= postfix:${PORTSDIR}/mail/postfix
.endif
-.if defined(WITH_DKIM)
+.if ${PORT_OPTIONS:MEXIM}
+RUN_DEPENDS+= exim:${PORTSDIR}/mail/exim
+.endif
+
+.if ${PORT_OPTIONS:MDKIM}
RUN_DEPENDS+= opendkim:${PORTSDIR}/mail/opendkim
.endif
-.if !defined(WITHOUT_DOVECOT)
+.if ${PORT_OPTIONS:MDOVECOT}
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
.endif
-.if !defined(WITHOUT_PROFTPD)
+.if ${PORT_OPTIONS:MCOURIER}
+RUN_DEPENDS+= courier:${PORTSDIR}/mail/courier
+.endif
+
+.if ${PORT_OPTIONS:MPROFTPD}
RUN_DEPENDS+= ${LOCALBASE}/libexec/proftpd/mod_sql_mysql.so:${PORTSDIR}/databases/proftpd-mod_sql_mysql
.endif
-.if defined(WITH_POWERDNS)
+.if ${PORT_OPTIONS:MPUREFTPD}
+RUN_DEPENDS+= pure-ftpd:${PORTSDIR}/ftp/pure-ftpd
+.endif
+
+.if ${PORT_OPTIONS:MPOWERDNS}
RUN_DEPENDS+= powerdns:${PORTSDIR}/dns/powerdns
.endif
-.if defined(WITH_LIBNSS)
+.if ${PORT_OPTIONS:MLIBNSS}
RUN_DEPENDS+= ${LOCALBASE}/lib/nss_mysql.so:${PORTSDIR}/net/libnss-mysql
.endif
-.if !defined(WITHOUT_WEBALIZER)
+.if ${PORT_OPTIONS:MWEBALIZER}
RUN_DEPENDS+= webalizer:${PORTSDIR}/www/webalizer
.endif
-.if defined(WITH_AWSTATS)
+.if ${PORT_OPTIONS:MAWSTATS}
RUN_DEPENDS+= awstats>=6.8:${PORTSDIR}/www/awstats
.endif
-.if defined(WITH_LOGROTATE)
+.if ${PORT_OPTIONS:MLOGROTATE}
RUN_DEPENDS+= logrotate:${PORTSDIR}/sysutils/logrotate
.endif