aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-s3backer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/fusefs-s3backer/Makefile')
-rw-r--r--sysutils/fusefs-s3backer/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/sysutils/fusefs-s3backer/Makefile b/sysutils/fusefs-s3backer/Makefile
new file mode 100644
index 000000000000..24d8e145319f
--- /dev/null
+++ b/sysutils/fusefs-s3backer/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= s3backer
+DISTVERSION= 1.5.0
+CATEGORIES= sysutils
+MASTER_SITES= https://s3.amazonaws.com/archie-public/s3backer/
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= bsdports@staktrace.com
+COMMENT= FUSE filesystem that uses Amazon S3 as a backing store
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libexpat.so:textproc/expat2
+
+GNU_CONFIGURE= 1
+# Need to have curl/curl.h on the include path. Is there a better
+# way to do this than sending CPPFLAGS to configure?
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include"
+
+USES= fuse pkgconfig ssl
+
+.include <bsd.port.mk>