aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gai-leds/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gai-leds/Makefile')
-rw-r--r--sysutils/gai-leds/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/gai-leds/Makefile b/sysutils/gai-leds/Makefile
new file mode 100644
index 000000000000..84f4c3a8932d
--- /dev/null
+++ b/sysutils/gai-leds/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gai-leds
+# Date created: 2007-06-12
+# Whom: Douglas Thrift <douglas@douglasthrift.net>
+#
+# $FreeBSD$
+
+PORTNAME= gai-leds
+PORTVERSION= 0.6
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gai
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= A GAI applet that displays the keyboard status leds
+
+LIB_DEPENDS= gai:${PORTSDIR}/x11-toolkits/gai
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnomeprefix
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|\(GNOMEDIR=\).*|\1"${PREFIX}"|; \
+ s|share\(/pixmaps\)|share/gnome\1|; \
+ s|:GNOME_|:GAI-|g; \
+ s|\(@APPLET_NAME@\)\(Applet\)|\1-\2|g; \
+ s|\(Applet\)_\(Factory\)|\1-\2|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|lib\(/bonobo\)|libdata\1|; \
+ s|share\(/pixmaps\)|share/gnome\1|; \
+ s|-O3||' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>