aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-control-center/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnome-control-center/Makefile')
-rw-r--r--sysutils/gnome-control-center/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index acbe1f0c2451..075ee3b879d6 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -6,27 +6,26 @@
#
PORTNAME= gnomecontrolcenter2
-PORTVERSION= 2.8.2
-PORTREVISION= 2
+PORTVERSION= 2.10.0
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/control-center/2.8
+MASTER_SITE_SUBDIR= sources/control-center/2.10
DISTNAME= control-center-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Control center for GNOME 2 project
-LIB_DEPENDS= xklavier.8:${PORTSDIR}/x11/libxklavier
+LIB_DEPENDS= xklavier.10:${PORTSDIR}/x11/libxklavier
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack gnomehier intlhack metacity nautilus2 \
- desktopfileutils
USE_GSTREAMER= yes
+USE_GNOME= gnomeprefix gnomehack intlhack metacity nautilus2 \
+ gnomemenus desktopfileutils
USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -42,6 +41,8 @@ GCONF_SCHEMAS= apps_gnome_settings_daemon_default_editor.schemas \
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|[{]prefix[}]/share/pixmaps|{datadir}/pixmaps|g'
+ @${REINPLACE_CMD} -e 's|mozilla-thunderbird|thunderbird|g' \
+ ${WRKSRC}/capplets/default-applications/gnome-default-applications-properties-structs.c
post-install:
@-update-desktop-database