aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-control-center/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnome-control-center/Makefile')
-rw-r--r--sysutils/gnome-control-center/Makefile29
1 files changed, 25 insertions, 4 deletions
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index 10c307825914..f11fdb353fa9 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -3,13 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/sysutils/gnomecontrolcenter2/Makefile,v 1.85 2005/10/03 15:29:07 ahze Exp $
#
PORTNAME= gnomecontrolcenter2
-PORTVERSION= 2.10.2
+PORTVERSION= 2.12.1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/control-center/2.10
+MASTER_SITE_SUBDIR= sources/control-center/2.12
DISTNAME= control-center-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -24,9 +25,11 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
USE_GSTREAMER= yes
+WANT_GNOME= yes
USE_GNOME= gnomeprefix gnomehack intlhack metacity nautilus2 \
gnomemenus desktopfileutils
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
+INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
@@ -38,9 +41,27 @@ GCONF_SCHEMAS= apps_gnome_settings_daemon_default_editor.schemas \
desktop_gnome_peripherals_keyboard_xkb.schemas \
fontilus.schemas themus.schemas
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+.undef WITHOUT_GNOME
+WITH_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mevolutiondataserver}!=""
+USE_GNOME+= evolutiondataserver
+CONFIGURE_ARGS+=--enable-aboutme
+PLIST_SUB+= ABOUTME=""
+.else
+CONFIGURE_ARGS+=--disable-aboutme
+PLIST_SUB+= ABOUTME="@comment "
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|[{]prefix[}]/share/pixmaps|{datadir}/pixmaps|g'
+ @${REINPLACE_CMD} -e 's|mozilla-thunderbird|thunderbird|g' \
+ ${WRKSRC}/capplets/default-applications/gnome-default-applications-properties-structs.c
@${REINPLACE_CMD} -e 's|/bin/tar|/usr/bin/tar|g ; \
s|/bin/gzip|/usr/bin/gzip|g' \
${WRKSRC}/capplets/theme-switcher/gnome-theme-installer.c
@@ -48,4 +69,4 @@ post-patch:
post-install:
@-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>