aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-power-manager/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnome-power-manager/Makefile')
-rw-r--r--sysutils/gnome-power-manager/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/sysutils/gnome-power-manager/Makefile b/sysutils/gnome-power-manager/Makefile
index 9eccabebf5a4..1baf7b279f21 100644
--- a/sysutils/gnome-power-manager/Makefile
+++ b/sysutils/gnome-power-manager/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnome-power-manager/Makefile,v 1.52 2009/03/07 18:42:22 marcus Exp $
+# $MCom: ports-stable/sysutils/gnome-power-manager/Makefile,v 1.5 2009/04/19 06:23:37 marcus Exp $
#
PORTNAME= gnome-power-manager
PORTVERSION= 2.24.4
-PORTREVISION= 1
+PORTREVISION= 4
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -20,7 +20,9 @@ BUILD_DEPENDS= docbook2html:${PORTSDIR}/textproc/docbook-utils \
${LOCALBASE}/share/sgml/docbook/4.1/catalog:${PORTSDIR}/textproc/docbook-410
LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal \
notify.1:${PORTSDIR}/devel/libnotify \
- execinfo:${PORTSDIR}/devel/libexecinfo
+ execinfo:${PORTSDIR}/devel/libexecinfo \
+ polkit-gnome.0:${PORTSDIR}/sysutils/policykit-gnome \
+ unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
USE_GETTEXT= yes
USE_BZIP2= yes
@@ -32,7 +34,8 @@ USE_GSTREAMER= good
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libwnck \
gnomedocutils gnomepanel
CONFIGURE_ARGS= --with-doc-dir=${PREFIX}/share/doc \
- --disable-docbook-docs
+ --disable-docbook-docs \
+ --enable-policykit
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"