aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-schedule/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnome-schedule/Makefile')
-rw-r--r--sysutils/gnome-schedule/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/gnome-schedule/Makefile b/sysutils/gnome-schedule/Makefile
new file mode 100644
index 000000000000..8bf97a9fe8f3
--- /dev/null
+++ b/sysutils/gnome-schedule/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: gnome-schedule
+# Date created: 2004-11-06
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-schedule
+PORTVERSION= 0.1.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME GUI for configuring a users crontab
+
+USE_PYTHON= yes
+USE_GNOME= gnomeprefix pygnome2
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+DATADIR= ${PREFIX}/share/gnome
+
+PORTDOCS= addingandediting.html index.html
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if defined(NOPORTDOCS)
+.for f in ${PORTDOCS}
+ @${REINPLACE_CMD} -e 's|${f}||' ${WRKSRC}/doc/Makefile.in
+.endfor
+.else
+ @${REINPLACE_CMD} -e 's|gnome-schedule-$$(VERSION)|gnome-schedule|' \
+ ${WRKSRC}/doc/Makefile.in
+.endif
+ @${REINPLACE_CMD} -e 's|/usr/share/icons|${X11BASE}/share/icons|; \
+ s|@prefix@/share|${DATADIR}|; \
+ s|/usr/local/share/|${DATADIR}|; \
+ s|/usr/share/|${DATADIR}|; \
+ s|/usr/bin/gnome-help|${X11BASE}/bin/gnome-help|; \
+ s|$$(prefix)/share/|$$(datadir)/|' \
+ ${WRKSRC}/src/*.* ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/pixmaps/Makefile.in
+
+.include <bsd.port.post.mk>