aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-settings-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnome-settings-daemon')
-rw-r--r--sysutils/gnome-settings-daemon/Makefile8
-rw-r--r--sysutils/gnome-settings-daemon/files/patch-libnotify58
2 files changed, 63 insertions, 3 deletions
diff --git a/sysutils/gnome-settings-daemon/Makefile b/sysutils/gnome-settings-daemon/Makefile
index 588bb471cf16..82a7702e639e 100644
--- a/sysutils/gnome-settings-daemon/Makefile
+++ b/sysutils/gnome-settings-daemon/Makefile
@@ -3,12 +3,12 @@
# Whom: Koop Mast <kwm@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnome-settings-daemon/Makefile,v 1.72 2010/11/15 13:50:07 kwm Exp $
+# $MCom: ports/sysutils/gnome-settings-daemon/Makefile,v 1.75 2011/04/25 19:56:57 mezz Exp $
#
PORTNAME= gnome-settings-daemon
PORTVERSION= 2.32.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,10 +17,12 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2 settings daemon
LIB_DEPENDS= canberra-gtk.0:${PORTSDIR}/audio/libcanberra \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
nss3.1:${PORTSDIR}/security/nss
RUN_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb
+CONFLICTS= gnome-settings-daemon-3.[0-9]*
+
USE_XORG= xxf86misc
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/sysutils/gnome-settings-daemon/files/patch-libnotify b/sysutils/gnome-settings-daemon/files/patch-libnotify
new file mode 100644
index 000000000000..1166875bf74b
--- /dev/null
+++ b/sysutils/gnome-settings-daemon/files/patch-libnotify
@@ -0,0 +1,58 @@
+From e1ab570b0dce479ba235e5542ea07d1b5bafc4c9 Mon Sep 17 00:00:00 2001
+From: William Jon McCann <jmccann@redhat.com>
+Date: Tue, 12 Oct 2010 03:35:45 +0000
+Subject: Require libnotify 0.6.0
+
+---
+diff --git a/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c b/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c
+index 9ca820a..f5964b9 100644
+--- plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c
++++ plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c
+@@ -608,9 +608,7 @@ ax_slowkeys_warning_post_bubble (GsdA11yKeyboardManager *manager,
+ gsd_a11y_keyboard_manager_ensure_status_icon (manager);
+ manager->priv->notification = notify_notification_new (title,
+ message,
+- "preferences-desktop-accessibility",
+- NULL);
+- notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon);
++ "preferences-desktop-accessibility");
+ notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000);
+
+ notify_notification_add_action (manager->priv->notification,
+@@ -747,9 +745,7 @@ ax_stickykeys_warning_post_bubble (GsdA11yKeyboardManager *manager,
+ gsd_a11y_keyboard_manager_ensure_status_icon (manager);
+ manager->priv->notification = notify_notification_new (title,
+ message,
+- "preferences-desktop-accessibility",
+- NULL);
+- notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon);
++ "preferences-desktop-accessibility");
+ notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000);
+
+ notify_notification_add_action (manager->priv->notification,
+diff --git a/plugins/xrandr/gsd-xrandr-manager.c b/plugins/xrandr/gsd-xrandr-manager.c
+index 02536a3..ef57d5b 100644
+--- plugins/xrandr/gsd-xrandr-manager.c
++++ plugins/xrandr/gsd-xrandr-manager.c
+@@ -1084,16 +1084,9 @@ error_message (GsdXrandrManager *mgr, const char *primary_text, GError *error_to
+
+ g_assert (error_to_display == NULL || secondary_text == NULL);
+
+- if (priv->status_icon)
+- notification = notify_notification_new_with_status_icon (primary_text,
+- error_to_display ? error_to_display->message : secondary_text,
+- GSD_XRANDR_ICON_NAME,
+- priv->status_icon);
+- else
+- notification = notify_notification_new (primary_text,
+- error_to_display ? error_to_display->message : secondary_text,
+- GSD_XRANDR_ICON_NAME,
+- NULL);
++ notification = notify_notification_new (primary_text,
++ error_to_display ? error_to_display->message : secondary_text,
++ GSD_XRANDR_ICON_NAME);
+
+ notify_notification_show (notification, NULL); /* NULL-GError */
+ #else
+--
+cgit v0.8.3.4