aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-system-monitor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnome-system-monitor/Makefile')
-rw-r--r--sysutils/gnome-system-monitor/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/sysutils/gnome-system-monitor/Makefile b/sysutils/gnome-system-monitor/Makefile
index 5bb1ec109e92..fbb8efd729fc 100644
--- a/sysutils/gnome-system-monitor/Makefile
+++ b/sysutils/gnome-system-monitor/Makefile
@@ -3,14 +3,13 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnome-system-monitor/Makefile,v 1.109 2007/10/15 21:02:38 mezz Exp $
+# $MCom: ports/sysutils/gnome-system-monitor/Makefile,v 1.117 2008/03/10 22:04:22 mezz Exp $
#
PORTNAME= gnome-system-monitor
-PORTVERSION= 2.20.2
+PORTVERSION= 2.22.0
CATEGORIES= sysutils gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-system-monitor/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
DISTNAME= gnome-system-monitor-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,7 +18,6 @@ COMMENT= GNOME 2 system monitor program
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop \
- pcre.0:${PORTSDIR}/devel/pcre \
gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
@@ -28,7 +26,8 @@ USE_GETTEXT= yes
USE_XLIB= yes
INSTALLS_OMF= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix intlhack gnomehack libwnck gnomevfs2 gnomedocutils
+USE_GNOME= gnomeprefix intlhack gnomehack libwnck gnomevfs2 gnomedocutils \
+ librsvg2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-pcrecpp
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \